3D printer extruder not heating up

uArm Serial No.: UARM0505170327
Firmware Version: 3.1.9

Operation System: Win10

uArm Controlling Method: Arduino,Cura 2.4.0, uArm Studio 1.1.12, uArm Firmware 3.1.9, USB connection to PC

Received uArm today. First try with 3D printer. Printer Monitor does not Refresh page: temp stays same as at startup of Printer Monitor screen. Has run for more that 1 hour. Still not heating up.Unit fFeels a bit warm. Progress just 0.09%, printing time 3.5 hours.
Is the unit broken?
How to check that?
How to gt a replacement unit?
Do I have to fill in a form somewhere?

Please help …


uArm User Facebook Group
Contact Us:
English Channel

Searched through other threads and came along a uFactory request to send the logging. It did not specify which one, but I found some Cura logfiles at:myname\AppData\Local\cura\cura.log.
It shows:

2017-06-27 01:38:01,473 - DEBUG - LocalFileOutputDevice.LocalFileOutputDevicePlugin.requestWrite [138]: Writing to Local File G:/UArm Robot Arm Sinoning/3D printing stl/Raspberry_Pi_Zero_Case/U_pizero-scase.gcode in text mode
2017-06-27 01:38:01,473 - DEBUG - SliceInfoPlugin.SliceInfo.run [50]: Sending anonymous slice info to [https://stats.youmagine.com/curastats/slice]…
2017-06-27 01:38:05,160 - ERROR - SliceInfoPlugin.SliceInfo.run [57]: An HTTP error occurred while trying to send slice information: HTTP Error 500: Internal Server Error
2017-06-27 01:38:10,197 - CRITICAL - cura.CrashHandler.show [32]: An uncaught exception has occurred!
2017-06-27 01:38:10,202 - CRITICAL - cura.CrashHandler.show [35]: Traceback (most recent call last):
2017-06-27 01:38:10,205 - CRITICAL - cura.CrashHandler.show [35]: File “C:\Users\Franz\AppData\Local\CuraForuArm\plugins\uArmSwiftPro\UArmSwiftPlugin.py”, line 213, in uarm_set_position
2017-06-27 01:38:10,208 - CRITICAL - cura.CrashHandler.show [35]: self._socket_thread.uarm_set_position(value)
2017-06-27 01:38:10,211 - CRITICAL - cura.CrashHandler.show [35]: AttributeError: ‘NoneType’ object has no attribute ‘uarm_set_position’
2017-06-27 01:38:10,363 - DEBUG - AutoSave.AutoSave._onTimeout [48]: Autosaving preferences, instances and profiles
2017-06-27 01:49:22,641 - CRITICAL - cura.CrashHandler.show [32]: An uncaught exception has occurred!
2017-06-27 01:49:22,648 - CRITICAL - cura.CrashHandler.show [35]: Traceback (most recent call last):
2017-06-27 01:49:22,651 - CRITICAL - cura.CrashHandler.show [35]: File “C:\Users\Franz\AppData\Local\CuraForuArm\plugins\uArmSwiftPro\UArmSwiftPlugin.py”, line 213, in uarm_set_position
2017-06-27 01:49:22,654 - CRITICAL - cura.CrashHandler.show [35]: self._socket_thread.uarm_set_position(value)
2017-06-27 01:49:22,657 - CRITICAL - cura.CrashHandler.show [35]: File “C:\Users\Franz\AppData\Local\CuraForuArm\plugins\uArmSwiftPro\UArmWebSocketClient.py”, line 155, in uarm_set_position
2017-06-27 01:49:22,660 - CRITICAL - cura.CrashHandler.show [35]: self.ws.send(json.dumps(msg, ensure_ascii=False))
2017-06-27 01:49:22,663 - CRITICAL - cura.CrashHandler.show [35]: File “C:\Users\Franz\AppData\Local\CuraForuArm\plugins\uArmSwiftPro\websocket_app.py”, line 119, in send
2017-06-27 01:49:22,665 - CRITICAL - cura.CrashHandler.show [35]: “Connection is already closed.”)
2017-06-27 01:49:22,669 - CRITICAL - cura.CrashHandler.show [35]: uArmSwiftPro.websocket._exceptions.WebSocketConnectionClosedException: Connection is already closed.

Hey FranzMa,
Would you please give us a picture or a video to let us know more details about it? Please double check the connections as the quick start guide as well.
And what’s more, does the laser engraving and blockly works well?
If the hardware problem we would give you the replacement for free, thanks!

Hi Tony,
started off with the suction cup and offline learning mode hand movements: OK, then Blockly all kind of move patterns: OK.
Next the laser engraver: star in paper: OK, my name as text at 100% speed: OK, but letters not completely separated at 100%: OK. Universal holder with a pencil: my name OK. Then I started the 3D printer setup: added the base board extension. Looks OK. Installed the delivered white PLA into the PTFE Tube and connected it using the 4-6 cable: OK. Plugged in the Extruder cable into the arm 6 pin socket with the arrow marker at the left hand side if looking at the uArm from the front (in the same way as the laser connector): looks OK.
Selected a basic .stl file (Raspberry Pi Zero from Adafruit) to print the casing (6:06:05 hours expected, 5 gr, 1.92 mtr) using the advised settings: PLA / profile uarmswiftpro, Recommended print Setup, nothing changed. Start off via Cura For uArm menu / Extensions / uArm Swift Pro / Printer Monitor. Set the Save Zero position and press the Print button.
Situation still the same after more than 6 hours, still 40 minutes left for the regular print. Fan of extruder has been blowing all the time: OK.
By uncoupling everything and restarting I notice the extruder does get heated up: last temp achieved at start of this 6 hour session is 171.6 degrees on Printer Monitor.

Looked again at the log file and suspected a software problem instead of a hardware one.
Installed uArm and Cura software onto another desktop PC and … everything works fine.
I suspect my Python versions on the original PC to cause the errors. I did not yet find the root cause, but will look into it later.
Made several 3D casings in the mean time. Just have to watch the advised areas between A and C (best is around B): coming too close to the uArm itself starts to lift the arm and the PLA is not fixed to the ground plate. I choose a glass plate (mirror) and TESA tape onto it.

So my problem is solved and I’m glad with the 3D printing results!

Very glad to hear that, and thanks for offering us so many details about the test.
BTW, did you join our Facebook robotic user group? We would be glad if you could share your ideas in our group and let more people to know about that. “uArm Robotic Arm User Group” https://www.facebook.com/groups/1653721141585397/
We do appreciate it!

Hoi Tony,

I was just admitted to that group. I will use the facebook group from now on …
Thanks for your help so far!