3d printing problem on new firmware & Cura (1.0.3)

Windows version of Cura - does not have “save zero” button on the extension window. no matter what i set the zero point to it digs into the surface. it worked fine before the updates.



Official Store
uArm User Facebook Group

English Channel

We removed the “save zero” button. Instead, zero point value will be saved automatically when you click “Print”.

Hi. There is a problem with the latest firmware which causes the nozzle to dig into the surface. See my video on Facebook.

May I have the link of the video? thanks.

I’m having the same problem with the new print monitor. It seems that the zero point is not being saved when hitting Print.
Regardless of position when hitting print, it always goes to the same Z (digging into bed) for the first layer (or two).

hoodel, revert to using 1.1.12 of studio and see if that helps. It has helped me.

@hoodel @mattp
Thanks for the feedback.
Could you upload your studio log and Cura log via Feedback Form?
There may be other users having the same problem and we’ll check that out today.

Sorry for the trouble.

I just uploaded the app.log (no studio log) and the Cura log.

In doing so, I noticed a config.json file under 3d printing. it has a attribute indicating the zero point. I’ll experiment with that tomorrow to see if it reflects the setting when ‘Print’ is clicked.

1 Like

Thanks, will check that out.

Please note that only Studio-1.1.13 is compatible with CuraForuArm-1.0.3.

Hi Matthew,

I received your log files too. Thanks.
What version of uArm Studio are you using?

i tried 1.1.13 & cura 1.0.3 no luck. had to revert to 1.1.12 to get it to work.

Hi @mattp

Thanks for your feedback. We’ve fixed the problem and will publish a new CuraForuArm today.
Sorry for the trouble.

I did the experiment to see changes in ~/uarm/studio/3DPrinting/config.json. Indeed, when you click ‘Print’, the new z-value is written to the file { “version”: “1.0.3”, “uarmzeropoint”: 9.2 }. Still, when it goes to print, it moves to z=0 (which is just below the bed), not the set point.

1 Like

1.0.4 seems to have solved this problem for me. Thank you.


Thanks it is ok for me now as well :slight_smile:

1 Like