Blockly does nothing

Firmware Version: Latest (released yesterday, 8/1)
Operation System: Win(10)

uArm Controlling Method: uArm Studio (also latest version)

Record and play works.
But Blockly does nothing at all.
I have a very simple command (move forward 10, reset) - I’ve tried changing the value of 10 higher in case that wasn’t enough to see movement).
When I hit the “play” button to run the commands, it does nothing at all.

This is a slightly more complicated version, but also does nothing at all. I added the “on keypress” to try to trigger the commands, and the beeps so I could tell if it was doing anything. But so far, nothing at all.

Any idea what I’m doing wrong?

<xml xmlns=""><variables></variables>
<block type="set_buzzer" id="C-Wos5;*wL-mdePci,dJ" x="12" y="38">
<value name="frequency"><block type="math_number" id="C[q1*?l{)X3kesMt*AL1"><field name="NUM">1000</field></block></value>
<value name="duration"><block type="math_number" id="R:-d_%~ua.p*edZ(Ai-V"><field name="NUM">0.1</field></block></value>
<block type="event_tip_sensor" id="iag9S`)ngt1jachc-a-R" x="13" y="113">
<comment pinned="false" h="80" w="160">This command let you trigger commands by pressing the suction cup (which is also a switch) of uArm.</comment>
<statement name="statement">
<block type="set_buzzer" id="1IQIgCW4(RFJ}5Pa()HG">
<value name="frequency"><block type="math_number" id="ph+;]@xR#Mqtgoy@,0Ea"><field name="NUM">1000</field></block></value>
<value name="duration"><block type="math_number" id="|h.FJ+M_pK,r#+.!lJSl"><field name="NUM">0.1</field></block></value>
<block type="controls_flow_statements" id="uK^-tJF;4|^Fz^W0yEaX"><field name="FLOW">BREAK</field></block>
<block type="event_keypressed" id="#:=swFz{s`tW7/.0M8CM" x="12" y="238"><field name="keycode">65</field>
<statement name="statement">
<block type="set_buzzer" id="-0%_z-ANO/Gil2`512nS">
<value name="frequency"><block type="math_number" id="SzYJzdY^r_hWa0[`X7_b"><field name="NUM">1000</field></block></value>
<value name="duration"><block type="math_number" id="2jdrqFH{V*2Ng5[!!xLV"><field name="NUM">0.1</field></block></value>
<block type="set_speed" id="/DZ`G!/7[(A6,I=}[1Yi"><field name="speed">1</field>
<block type="move" id="j0N}D^IzT}#YkFr~^J7n"><field name="orientation">forward</field>
<comment pinned="false" h="80" w="160">Let uArm move relatively in absolute coordinates.</comment>
<value name="value"><block type="math_number" id="s.$x-W|]bnT+^2H}5~VD"><field name="NUM">25</field></block></value>
<block type="reset" id="vLZ]~!(NW$XhJO,~{EQ~">
<comment pinned="false" h="80" w="160">Reset uArm to its home position.</comment>
<block type="controls_whileUntil" id="]$#aWC2S6M0]GB4XYqWN">
<field name="MODE">UNTIL</field>
<value name="BOOL"><block type="logic_boolean" id="(eshAn/9IV-pcz9:.bDz"><field name="BOOL">FALSE</field></block></value>
<statement name="DO">
<block type="move" id="mSJ}Wq|y2Y)D}/S]Gu7l"><field name="orientation">down</field>
<comment pinned="false" h="80" w="160">Let uArm move relatively in absolute coordinates.</comment>
<value name="value"><block type="math_number" id="#i*;u#f27pEYPm:biXm+"><field name="NUM">10</field></block></value>
<block type="set_pump" id="wE)@qL#GEnih:6z7aPmP"><value name="value"><block type="ON" id="W^9E(wyCNKiA!JM1N8Jd"><field name="on_off">TRUE</field></block></value>
<block type="set_speed" id="02M(?l?PTQCy:a%=p(DH"><field name="speed">1</field>
<block type="move" id="@)q0_^r/4REj9J6^{GY/">
<field name="orientation">up</field>
<comment pinned="false" h="80" w="160">Let uArm move relatively in absolute coordinates.</comment>
<value name="value"><block type="math_number" id="S3,h@Y4Av:WVPAUiJdW~"><field name="NUM">25</field></block></value></block>

Hi @Rich

So sorry for the problem.
Could you fill in this Feedback Form with your log files?
We’ll locate the problem as soon as we had your logs.


Or you could deal with the problem in the first place it’s brought to you, instead of making MORE work for your customer…

The form has the exact same questions as here, so there’s no point duplicating my effort.


I reproduce the .xml you provided:

The command “break out of loop” is supposed to be used within a loop.
That’s why the whole Blockly is in error. Just delete the “break out of loop” and try again.

I can see that you want uArm to move down until suction cup is pressed.

We’ll add commands like “suction cup pressed” “button pressed” in the future versions and you can put that after the “repeat until” block.

Thanks! I’ll try that when I get some time. I’m sure I had a simple version of this at one point where there was no loop, but I guess I must have not tried it at that point (or just had the break elsewhere).

Any chance of getting some error messages (compile errors?) in the future?

We’ll surely consider this. Thanks for your feedback!