Calibration problems

Hi there, I just received the uArm metal and I am trying out the QuickStart examples with uArmForArduino, but I got some issues.

  1. When I tried the MoveTo example with uarm.moveTo(0,-20,20), the arm goes to one place first and move to another, shouldn’t it move to (0,-20,20) in one-go?
    And if I set uarm.moveTo(0,0,0,1,2). It should stay still, right? But the arm moves when I load the code…

  2. When I tried the Get XYZ Example, the Arduino Serial monitor always shows The current location is (0,0,0). It means that the Arduino can’t read the location of the arm tip. How does it come?

  3. And for the calibration, do I need to do anything to calibrate the hardware, such as the motors, arm configurations?

I am new to the uArm, could anyone help me figure these issues out? Many thanks.


You should be using the library, calibration code and examples from here:

(pulling the latest master is best)

You should calibrate once with this method

and then no need to calibrate again unless you calibrate with the older “learning mode” method.

The descriptions you give of arm movement are indeed incorrect and the location (0,0,0) is most certainly wrong. I strongly suspect that the arm has not been calibrated with the correct method (there are two methods).

Let me know if this works for you…

Hi DCorboy,

Thanks for your instructions, it works!
Actually i did the first step of calibration (running calibration code) but forgot to do the second step (manual calibration). I think that it why it failed before.

That is good news to hear!