Can't make Cura Work with my uArm Swift Pro

uArm Serial No.: (the No. at the bottom of each uArm reading “UARM-XXXXXXXXXX”) 050170001

Firmware Version: 3.1.3

Operation System: Mac OS 10.11.6

uArm Controlling Method: uArm Studio 1.0.50

With my uArm connected to UCS, I select 3D Printing and Cura 2.4.0 opens. But when I select Printer Monitor in Cura, I get a message saying uArm Studio is not connected. Please open uArm Studio and click ‘Reconnect’“”
Clicking on Reconnect does nothing!
I’ve searched the forum and couldn’t find any help.
I am deeply disappointed! NOTHING works reliably!! I’ve had my uArm Swift Pro for a month now and haven’t been able to do anything with it!! The getting started Guide is vey shallow and I can’t find tutorials anywhere!!!

uArm User Facebook Group
Contact Us:
English Channel

Hi Risco,

Did you keep uArm Studio open all the time? The “Reconnect” only works when Studio is open.

I tried to open 3D Printing on the same operation system but it works fine and I couldn’t reproduce the problem.

Yes! I tried every way possible, in sll combinations!
This is so frustrating! It’s been nothing but disappointment after disappointment.

As you can see, my uArm is connected but when I click the 3D Printing option, it opens Cura and, when I select Printer Monitor, I get the message that it’s not connected. Reconnect does NOTHING, even with uArm Studio running in the background.

One more detail: EVERY TIME i try to quit Cura, I get the message the it quit Unexpectedly, even if I use the Quit Cura option in the Menu.

Has anybody succeeded in using the 3D printer function?

Hi Risco, I’ve messaged you 3 days ago to ask you for the log.

Please email me the log so we can figure out the problem ASAP. Thanks!

same here CURA is not connecting to at all. Windows 10 pro

Hi sajid, I messaged you too.

Just submitted the query using online portal again. Please reply

we’re locating the problem. will reply asap.

This is beyond frustrating now! I have followed your instructions and nothing works as planned, especially with the 3D printing function, which does not work at all!! I am almost ready to throw my towel and give up. This means that I will be throwing more than US$700 in the trash very soon!

I’m really sorry about the experience you’re having with it. I managed to get mine 3D printing yesterday, but came across many frustrating similar things. I found this thread here and my Cura is doing almost the same thing. It doesn’t recognize or say the printer is connected in the main print screens, but if I go to the monitor, it has the info there and I can set the zero point. Weirdly enough there was a print button there and it printed when I clicked it. It used the defaults which are super crappy (10% infill? - Seriously?). I managed to screw around with what was left of the final print and make my item into a functional do-dad, so I’m not totally disappointed.

It is unfortunate that the support on the forum here isn’t really helpful in resolving these issues yet. I need to get my Cura to operate normally so that I can adjust print settings. I need it to not crash stupidly. Those are definitely issues that need uFactory’s attention right now or very soon. I know they are laser focused on shipping out their remaining orders though, so that may be why they aren’t that responsive. They should be finishing up their final rounds soon, so I would expect a much better support experience at that time.

I see almost 10 days since your last post so I could imagine you’ve thrown the thing through the window by now. Or were you able to make any progress on it??

** EDIT **

I wanted to also speculate here if maybe the setup we have is the reason it’s not operating in an optimal way… I have the same MacBook Pro as you. I did notice you’re on El Capitan, but I’m on Sierra. It might be part of the reason I was able to get a print and you were not. On my older iMac with El Capitan, it wouldn’t even recognize the uArm in uArm Studio. That was when I switched to the MBP. I think they probably had this set up on Windows for their tests and assumed it would all work in like fashion on Macs. They’re probably a bit frustrated by this as not many Chinese use Macs. I’m going to try booting into my Windows 10 bootcamp partition and seeing if any of this will work better and give an update when I know.

1 Like

Thanks for your feedback.
We’ll hurry up the debugging and update CuraForuArm in the next two weeks.

1 Like

Cura is also telling me that the uArm is not connected in the main print window, however if I go to “extensions” and choose the uArm for the printer Cura is able to connect with my uArm and I am able to print 3D objects even though the main icon in the upper right hand corner of the Cura App says that it can not connect to a printer. Here is a video I made of my setup for the poster that asked if anyone else was able to print in 3D.

1 Like

Any update on the progress of the CuraForuArm update?

Wow what a drunk camera! I almost fell over.

a new version will be published these two days.

1 Like