Doesn't connect to Mac, uarmcore quit unexpectedly

It seems I’m having the same behavior as before the new build. uarmcore quit unexpectedly.

Process: uarmcore [710]
Path: /Applications/
Identifier: uarmcore
Version: ???
Code Type: X86-64 (Native)
Parent Process: uArmStudio [704]
Responsible: uarmcore [710]
User ID: 501

Date/Time: 2017-07-14 13:33:43.230 -0400
OS Version: Mac OS X 10.12.5 (16F73)
Report Version: 12
Anonymous UUID: EFB46D4C-9C60-DA39-A1E7-51EE4CD2D053

Time Awake Since Boot: 71 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue:

Exception Type: EXC_CRASH (SIGILL)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Thread 0 Crashed:: Dispatch queue:
0 libsystem_kernel.dylib 0x00007fffe6fb2d42 __pthread_kill + 10
1 libsystem_pthread.dylib 0x00007fffe70a0457 pthread_kill + 90
2 libsystem_c.dylib 0x00007fffe6ec9497 raise + 26
3 uarmcore 0x000000010e513747 0x10e50f000 + 18247
4 uarmcore 0x000000010e511582 0x10e50f000 + 9602
5 uarmcore 0x000000010e50fd24 0x10e50f000 + 3364

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000004 rcx: 0x00007fff516efeb8 rdx: 0x0000000000000000
rdi: 0x0000000000000307 rsi: 0x0000000000000004 rbp: 0x00007fff516efee0 rsp: 0x00007fff516efeb8
r8: 0x0000000000000004 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000287
r12: 0x00007f9405801000 r13: 0x00007f9405801878 r14: 0x00007fffefdeb3c0 r15: 0x0000000000000000
rip: 0x00007fffe6fb2d42 rfl: 0x0000000000000286 cr2: 0x00007f940550046e

Logical CPU: 0
Error Code: 0x02000148
Trap Number: 133

Binary Images:
0x10e50f000 - 0x10e515fff +uarmcore (???) <3B962917-7CFB-3C42-A75A-36251EE8895D> /Applications/
0x119dc6000 - 0x119e03dc7 dyld (433.5) <322C06B7-8878-311D-888C-C8FD2CA96FF3> /usr/lib/dyld
0x7fffe5867000 - 0x7fffe5868ffb libSystem.B.dylib (1238.60.2) /usr/lib/libSystem.B.dylib
0x7fffe5a1a000 - 0x7fffe5a70ff7 libc++.1.dylib (307.5) <0B43BB5D-E6EB-3464-8DE9-B41AC8ED9D1C> /usr/lib/libc++.1.dylib
0x7fffe5a71000 - 0x7fffe5a9bfff libc++abi.dylib (307.3) <30199352-88BF-30BD-8CFF-2A4FBE247523> /usr/lib/libc++abi.dylib
0x7fffe658e000 - 0x7fffe6963bc7 libobjc.A.dylib (709) <54CD8D1A-5C98-3559-B13A-932B3D3DD338> /usr/lib/libobjc.A.dylib
0x7fffe6d88000 - 0x7fffe6d99ff3 libz.1.dylib (67) <46E3FFA2-4328-327A-8D34-A03E20BFFB8E> /usr/lib/libz.1.dylib
0x7fffe6da8000 - 0x7fffe6dacff7 libcache.dylib (79) <093A4DAB-8385-3D47-A350-E20CB7CCF7BF> /usr/lib/system/libcache.dylib
0x7fffe6dad000 - 0x7fffe6db7fff libcommonCrypto.dylib (60092.50.5) <8A64D1B0-C70E-385C-92F0-E669079FDA90> /usr/lib/system/libcommonCrypto.dylib
0x7fffe6db8000 - 0x7fffe6dbffff libcompiler_rt.dylib (62) <55D47421-772A-32AB-B529-1A46C2F43B4D> /usr/lib/system/libcompiler_rt.dylib
0x7fffe6dc0000 - 0x7fffe6dc8fff libcopyfile.dylib (138) <819BEA3C-DF11-3E3D-A1A1-5A51C5BF1961> /usr/lib/system/libcopyfile.dylib
0x7fffe6dc9000 - 0x7fffe6e4cfdf libcorecrypto.dylib (442.50.19) <65D7165E-2E71-335D-A2D6-33F78E2DF0C1> /usr/lib/system/libcorecrypto.dylib
0x7fffe6e4d000 - 0x7fffe6e7efff libdispatch.dylib (703.50.37) <6582BAD6-ED27-3B30-B620-90B1C5A4AE3C> /usr/lib/system/libdispatch.dylib
0x7fffe6e7f000 - 0x7fffe6e84ffb libdyld.dylib (433.5) /usr/lib/system/libdyld.dylib
0x7fffe6e85000 - 0x7fffe6e85ffb libkeymgr.dylib (28) <7AA011A9-DC21-3488-BF73-3B5B14D1FDD6> /usr/lib/system/libkeymgr.dylib
0x7fffe6e93000 - 0x7fffe6e93fff liblaunch.dylib (972.60.2) /usr/lib/system/liblaunch.dylib
0x7fffe6e94000 - 0x7fffe6e99ff3 libmacho.dylib (898) <17D5D855-F6C3-3B04-B680-E9BF02EF8AED> /usr/lib/system/libmacho.dylib
0x7fffe6e9a000 - 0x7fffe6e9cff3 libquarantine.dylib (85.50.1) <12448CC2-378E-35F3-BE33-9DC395A5B970> /usr/lib/system/libquarantine.dylib
0x7fffe6e9d000 - 0x7fffe6e9effb libremovefile.dylib (45) <38D4CB9C-10CD-30D3-8B7B-A515EC75FE85> /usr/lib/system/libremovefile.dylib
0x7fffe6e9f000 - 0x7fffe6eb7ff7 libsystem_asl.dylib (349.50.5) <096E4228-3B7C-30A6-8B13-EC909A64499A> /usr/lib/system/libsystem_asl.dylib
0x7fffe6eb8000 - 0x7fffe6eb8ff7 libsystem_blocks.dylib (67) <10DC5404-73AB-35B3-A277-A8AFECB476EB> /usr/lib/system/libsystem_blocks.dylib
0x7fffe6eb9000 - 0x7fffe6f46fef libsystem_c.dylib (1158.50.2) /usr/lib/system/libsystem_c.dylib
0x7fffe6f47000 - 0x7fffe6f4affb libsystem_configuration.dylib (888.60.2) /usr/lib/system/libsystem_configuration.dylib
0x7fffe6f4b000 - 0x7fffe6f4efff libsystem_coreservices.dylib (41.4) <7D26DE79-B424-3450-85E1-F7FAB32714AB> /usr/lib/system/libsystem_coreservices.dylib
0x7fffe6f4f000 - 0x7fffe6f67fff libsystem_coretls.dylib (121.50.4) /usr/lib/system/libsystem_coretls.dylib
0x7fffe6f68000 - 0x7fffe6f6efff libsystem_dnssd.dylib (765.50.9) /usr/lib/system/libsystem_dnssd.dylib
0x7fffe6f6f000 - 0x7fffe6f98ff7 libsystem_info.dylib (503.50.4) <611DB84C-BF70-3F92-8702-B9F28A900920> /usr/lib/system/libsystem_info.dylib
0x7fffe6f99000 - 0x7fffe6fbbff7 libsystem_kernel.dylib (3789.60.24) <6E9E485F-91F6-36B7-A125-AE91DC978BCC> /usr/lib/system/libsystem_kernel.dylib
0x7fffe6fbc000 - 0x7fffe7003fe7 libsystem_m.dylib (3121.6) <86D499B5-BBDC-3D3B-8A4E-97AE8E6672A4> /usr/lib/system/libsystem_m.dylib
0x7fffe7004000 - 0x7fffe7022ff7 libsystem_malloc.dylib (116.50.8) /usr/lib/system/libsystem_malloc.dylib
0x7fffe7023000 - 0x7fffe707cffb libsystem_network.dylib (856.60.1) <369D0221-56CA-3C3E-9EDE-94B41CAE77B7> /usr/lib/system/libsystem_network.dylib
0x7fffe707d000 - 0x7fffe7086ff3 libsystem_networkextension.dylib (563.60.2) /usr/lib/system/libsystem_networkextension.dylib
0x7fffe7087000 - 0x7fffe7090ff3 libsystem_notify.dylib (165.20.1) /usr/lib/system/libsystem_notify.dylib
0x7fffe7091000 - 0x7fffe7099fe7 libsystem_platform.dylib (126.50.8) <897462FD-B318-321B-A554-E61982630F7E> /usr/lib/system/libsystem_platform.dylib
0x7fffe709a000 - 0x7fffe70a4ff7 libsystem_pthread.dylib (218.60.3) /usr/lib/system/libsystem_pthread.dylib
0x7fffe70a5000 - 0x7fffe70a8ff7 libsystem_sandbox.dylib (592.60.1) /usr/lib/system/libsystem_sandbox.dylib
0x7fffe70a9000 - 0x7fffe70aaff3 libsystem_secinit.dylib (24.50.4) /usr/lib/system/libsystem_secinit.dylib
0x7fffe70ab000 - 0x7fffe70b2ffb libsystem_symptoms.dylib (532.50.47) <3390E07C-C1CE-348F-ADBD-2C5440B45EAA> /usr/lib/system/libsystem_symptoms.dylib
0x7fffe70b3000 - 0x7fffe70c6ff7 libsystem_trace.dylib (518.60.2) <6B145B10-5874-3E89-90CD-D370DB475BA1> /usr/lib/system/libsystem_trace.dylib
0x7fffe70c7000 - 0x7fffe70ccffb libunwind.dylib (35.3) <3D50D8A8-C460-334D-A519-2DA841102C6B> /usr/lib/system/libunwind.dylib
0x7fffe70cd000 - 0x7fffe70f6ff7 libxpc.dylib (972.60.2) <1C9AF716-69DF-359F-85E9-7DFDE362F9A2> /usr/lib/system/libxpc.dylib

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 125
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=156.9M resident=0K(0%) swapped_out_or_unallocated=156.9M(100%)
Writable regions: Total=101.6M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=101.6M(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Kernel Alloc Once 8K 2
MALLOC 93.6M 15
MALLOC guard page 16K 4
Stack 8192K 2
__DATA 1472K 43
__LINKEDIT 148.9M 4
__TEXT 8140K 42
shared memory 8K 3
=========== ======= =======
TOTAL 315.9M 108

Model: MacBookPro9,1, BootROM MBP91.00D3.B15, 4 processors, Intel Core i7, 2.6 GHz, 16 GB, SMC 2.1f175
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In
Graphics: NVIDIA GeForce GT 650M, NVIDIA GeForce GT 650M, PCIe, 1024 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x029E, 0x434D5358384758334D314131363030433130
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x029E, 0x434D5358384758334D314131363030433130
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF5), Broadcom BCM43xx 1.0 (
Bluetooth: Version 5.0.4f18, 3 services, 27 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: Samsung SSD 850 EVO 1TB, 1 TB
Serial ATA Device: OPTIARC DVD RW AD-5970H
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: FaceTime HD Camera (Built-in)
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Hub
USB Device: Apple Internal Keyboard / Trackpad
USB Device: IR Receiver
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB 3.0 Bus
Thunderbolt Bus: MacBook Pro, Apple Inc., 25.1

Hi, could you report your problem via this feedback form with the log?

HI - the form says it’s for the beta version only. I have tried about 25 times to download the 168MB file from the beta site without luck. Fails every time after a very slow start. I’m still using the released version (2nd public build with the same release number and newer date).

I see.
uArm Studio-1.1.12 still has the connection problem. We fixed it in the beta(only for testing now). We’ll fix the downloading problem of beta soon. Sorry about that.

Same problem here. “UArm Core” quits unexpectedly upon launch of UArm Studio and fails to connect to the UArm.

I am on MacOS Sierra 10.12.5 and UArm Studio 1.1.12 UArm Core 0.6.23
I test also with a PC Windows 7 professionel 64bits

Hoping for a fix soon so I can play with this thing!

For those who had a connection problem,
please try the latest Studio Beta, which has a new uarmcore.
It’s not on our official website yet.
If you had problems using the Studio Beta, please report to us via the Beta Feedback Form.
Thanks a lot!

1 Like

I tested beta version. I can connect with uArmPro. Teaching and block-program tests are successful. but Laser-engraving test are failed. I reported beta-report-form with logs. I hope this report will be helpful.

1 Like

Thanks JunHo! I received your log files and will follow up this week.

The download speed for the beta software is so slow (25kb/s) that my download times out after getting through only about 16MB of the 175MB file size.

I’ve tried downloading at different times of the day, but so far have been unable to get through the download of the beta software!

Sorry for the problem.
I’ll put the beta on Google Drive later.

Has this been put on Google Drive? I have tried to download for the last two days and only get about 20mb before the download quits. I also am having a connectivity issue and can’t connect from UARM studio. I have sent a support request with info but haven’t heard back.

I can confirm that the laser functionality is not fixed in the new beta release. Looking forward to an update!

If you failed to download from,

Please get the latest beta (v1.1.13c2) here:
Connecting... , or


I downloaded dmg file from beta sites. (~.13.c2) but OS showed the message as 'It’s damaged. file It shoulde be removed (not exact expresstion) '. Anyway I cannot install new versions.

please try:

I found the reason of execution error. Because of anti-virus application protection, UArmStudio cannot be run. Anti-virus app prevent from running studio because anti-virus regards studio is modified after signed. I can it run at terminal by command and I successed to run the laser-engraving feature.

1 Like

Same as @JunHo_SEO: “uArmStudio” is damaged and can’t be opened. (Using uArmStudio-beta-1.1.13-c2 on Mac OS X Sierra 10.12.6 )

Patching an application that crashes on opening, with a version that is damaged and doesn’t even open. This is getting kind of frustrating @Cleo.

Hi @max-s

The “damaged” window is popped out because Apple’s gatekeeping policy.
We resolved this issue for the latest version. Please download Studio-1.1.13p4 from our website. Thanks!

Awesome, thanks! Here’s the direct link for anyone also trying to fix the issue: Link

1 Like

I upgraded to uArmStudio 1.1.13 and the arm began working perfectly. HOWEVER, the laser fails to turn on. Arm is clearly printing correctly it’s just that the laser is turned off. Now what?