Drawing broken with uArmStudio 1.1.13-p1/firmware 3.1.16

After zero point adjustment the uArm goes down twice on the z-axis before starting to draw. If I put a pen into the universal holder, the arm will actually lift itself up!

Here is a video showing the issue (for the z-axis issue I didn’t even bother putting a pen into the universal holder.):

The bottom line is that I have two uArm Swift Pros since almost two months now and they’re just useless.

Really guys, this is the 3rd hardware startup I back that overdelivers on the hardware perk and completely fails to on the software side.
The fact that you ship software ‘updates’ that break features that worked before seems to indicate you have no or a broken QA process in place and no systematic manual testing.


Hi @virtualritz

We’ve reproduce the problem and are dealing with it now.
After fixing it, we’ll publish a Beta version on the beta site first. I’ll keep you informed.

I want to apologise for updating the software without a thorough testing. We’ll be more cautious for the future updates.

Thanks for your feedback.

Hi @virtualritz

We’ve fixed this problem and updated a beta.
You may download 1.1.13p3 in the beta site if you want: http://beta.ufactory.cc/#/

Hi Ufactory Team,

I just downloaded the 1.1.13p3 Beta and the drawing ist still broken.
Whatever 0-point I set up, the arm moves down just above the surface and “draws”.
When I put in a pen, it still lifts the arm up completely.


  • Kurt

Hi @kurt.b

We’ve uploaded an official p3 on our website.
Please download here: http://www.ufactory.cc/#/en/support/

Let me know for further problems. Sorry for the trouble.

Hi Ufactory Team,

thanks for the quick fix.
For the “Outline” option drawing works fine now.
But for the “Black & white” and “Vector” option the Uarm behaves like in Laser mode, also when in drawing mode => whatever i set as 0-value it moves up and starts “drawing”.


  • Kurt

Hi @kurt.b
Could you send me a video of the problems?

Hi Ufactory-Team,

here are two videos of the behaviour:

Hope this helps.
Btw. in Laser mode with the laser attached all three modes work fine.


  • Kurt

Thanks for the feedback.
We’re fixing it now. Sorry about that.