Heater failing after downgrading to 3.2.0

uArm Serial No.: D43639DAFC06

Firmware Version: 3.2.0

Operation System: Win(10)

uArm Controlling Method: COM port


I have written my own software to control the arm from a windows machine using the COM port, to do some special 3D printing jobs. When I opened up uArm Studio and saw there was a new firmware version (4.0+) available, I installed it. I read the popup about 3d functionality being removed, but I just hoped the G-code commands for the 3d printing were still available.

When I found out they weren’t available in the new firmware, I flashed it back to version 3.2.0 using uArm Studio. However, now if I try to heat the nozzle using G-code commands, it says ok, says it is supplying power to the heater (@127 when using M105 command), but doesn’t heat up and eventually throws a temp error.

I also tried to reflash the software using the .hex and the flash tool, but the issue persists.

Please tell me how to fix this, since I am currently unable to use the arm, and it worked before.

Do you used the intergrated Cura in the uArm Studio to try the 3D priting function?

Yes, It gives me an error message to check if the extruder is plugged in properly and otherwise contact support.

It does read the correct temperatures.

Could you provide more details? How about shoot a video about the process of your opetating and send to us?
And could you send us the log file of uArm Studio?
You could refer to item 12 of this post to get the log files.

I was able to resolve the issue by manually flashing 3.1.17 and then flashing it with 3.2.0 again. Just re-flashing 3.2.0 didn’t work (tried multiple times).

Thank you for the support!

Oh, that’s great.