How to Disable Zero Position in xArm Studio

When I have gripper attached to xArm that is mounted to table, zero position collides gripper with table. This is clearly documented in manual. However, is there a way to disable or set zero position, such as is provided for Initial Position in settings?

Dear Garram,

Sorry there is no way and do not recommend modifying the zero position, as it is related to the calibration of the robotic arm. Please use the initial position. Is it possible to modify the mounting position?

Or you may check if ‘Settings-Safety-Safety Boundary’ can meet your need, but it will reduce the working space of the robotic arm.

Best regards.

Hi Michael,

I’m not quite sure what your use case is, but in case it’s any help I’d like to point you to the tool I’m developing called Rebellum at It takes care of this issue where the gripper collides with the table. It’s free to download and I’d be happy to tailor features to your needs as I continue to develop the app.

And if you find it useful, you can use promo code REBELLUM100 for a free month of the full feature app.

Curious to hear what you think,