Is there any way to program swiftPro under Arduino IDE?

uArm Serial No.: UARM-050517004F

Firmware Version: 3.1.9

Operation System: WIN7/WIN10

uArm Controlling Method: wanted Arduino…but…

I can’t find the lib in Arduino1.8.2 to program swiftPro! Metal did, but can’t go through the compile even the sample .ino in the folder.

Now, the arm is stand on my desk, but just a toy…

Or, substitude way to program the little robot is welcomed.

uArm User Facebook Group
Contact Us:
English Channel

Hi, you can find Arduino Library for Swift Pro here:

Well, you can always program the robot by sending of GCode commands through the serial port connection. The communication protocol for that is explained in the start guide.

And by the way, @Cleo… is this github repository where the source code of the uArm Swift Pro firmware is? This is, can I compile this and upload it to the Mega 2560 in uArm Swift Pro and have the very same last firmware verdion (3.1.9)?

@Cleo, Hi, is the Arduino Library for Swift Pro on GitHub different from the one found in Arduino Lib Manager? BTW, the more info link returns an error 404 when i try to look it up.

Hi ebto,

Please use the Arduino Library for Swift Pro for Github.
The one in Arduino Lib Manager is for uArm Metal and is outdated. Sorry for the confusion.

Yes, you can compile and upload it to Swift Pro and you’ll have the latest firmware. Or you can use the in-app update in Studio to update firmware.

Thank you Cleo,

I’ll try.

Best regard.

Hi Ebto,

As far as I know, this lib is for Metal.

Hi YoHidden,

Kindly, would you please give me the link point to the ‘start guide’ you mentioned?

Many thanks!

Hi @i486, the doc is in the official download page and its link is…

At the end of this doc, the GCode based communication protocol is described.


1 Like

Hey Cleo while trying arduino ide with my swift arm pro am unable to include the zip file from git hub to arduino library.
I want to update firmware through arduino ide

Hi YoHidden,

Thank you so much!

I didn’t notice that, stupid me.:grin:

@Cleo I’m having the same problem adding the library to the arduino IDE, Can’t add it.

Hi all together,

I´m programming the uArm Metal with the library. This works fine, but to programm the uArm Swift Pro it´s the best way ito send GCode commands through the serial port connection (in sum it´s a 100% seriel communication with the uArm. This works very well. I´m working wirh a Java - Programm and a Serial.class and with that I can controll the uArm SP. Noo problem and for me it´s a much better way to control an write programms like the direcht way via a Arduino - programm.

I have triied only a few commands up to now and they work very well. I go step by step further on to explore and to write a documentation for the rest of the commands, with the goal to have a more easier documentation for pupis projects (school).

Best regards jmhems (Germany)

Hi all,
the uArm firmware as it is in the github is a platformIO project.
In order to rebuild it I took the following steps:
Install Atom editor (depending on your already installed tools you might need to install python and clank)
then install the platformIO addon
now open the swiftproforarduino\ folder as project
now have Atom build the code PlatformIO->build first build will yield some warnings because the avr/arduino environment is still missing.
after the build you have a firmware.hex in the swiftproforarduino.pioenvs\megaatmega2560 subdirectory
The firmware.hex it builded right now seems to be different than the official 3.2.0 thats probably because there are additional commits already in the repository.

But at least it worked :slight_smile:

Stay safe

Hey FeKo,
So just trying to understand what you said that I need to use Atom in order to make UARM accept the arduino code ?
Also I am trying to upload the example arduino sketch given in the zip library given on the GitHub as it is to the UARM swift Pro in the standard way we program an Arduino and that did’nt work for me as i assumed that since its a Mega in it, I would like to know if anyone has used arduino and has successfully made it worked and willingto shear notes that will be great!

Thanks everyone.


Hi Jay,
using Atom I was able to compile a .hex file wich the could have been uploaded to the uArm using the FW upgrade tool, but I never really uploaded a selfcompiled FW to my uArm.
In the Facebook group people were able to build a firmware with the Arduino IDE and upload it.
Can you compile the FW?
Do you maybe have some programms active which might interfere with the bootloader procedure of the arduino mega. (uArm Studio maybe)
Also my understanding is that compiling a FW for an Arduino mega should work.

best regards

I just compiled the modifications required to use a heated bed with the uArm and everything just worked as I would expect with any Arduino, so maybe you can give more details about your situation?
Best regards

Hey Feko,
So, begining from start I am trying to use uarm to pick and place a card using suction cup and I am trying to increase the speed of the arm. As using the Blocky I believe the sofware won’t be able to go full speed. Hence I am trying to upload an example sketch from one ofthe library avaliable on github the Library is UF-uarm-master. Also while doing all of this I didn’t had the Uarm studio open and also I was able to comple the entire FW but when I uploaded it in the arm the only thing it was doing was blinking blue and green light alternately.


Hi Jaydeep,
so it seems that the compile and upload succeded.
Did yo use the swiftpro FW?

As I understood you were trying to do some modifications to the FW.
Can you connect to the Arm using the Arduino serial interface (as described in the developers guide)