Laser Etching broken with uArmStudio 1.1.13-p1

uArm Serial No.: UARM0505170732
Firmware Version: 3.1.18
Operation System: Mac

Problem #1 was flashing the firmware. This latest uArmStudio version did not work. When I tried to update the firmware, I saw a “USB Disconnected” message and then no progress at all. The firmware didn’t flash.

To get around this I had to use the FirmwareFlashTool program and I luckily found almost the right firmware here: Releases · uArm-Developer/SwiftProForArduino · GitHub

However, jumping around that first problem was not enough. My arm is still broken.

So on to Problem #2 - Whenever I try to start the laser process, the arm will respond while setting the 0 position, but after that is set and I click continue, nothing happens. The arm does not move. The laser does not activate, and the UI never advances from 0%.

Actually, now it looks like just going to the laser/draw option in the software crashes the whole app. So that’s lovely.

At least in the previous version I could burn a few things. This current version is unusable :frowning:

Hi @tomseago
So sorry for the trouble. We’re fixing it now. I’ll keep you updated.

Using 1.1.13-p2 now, laser etching is not completely broken but i am unable to engrave vector graphics.

Adding images works, these will engrave as raster graphics.

Adding svg file with a simple circle still engraves as raster image.

Adding pattern from side causes program to crash.

Adding text (black light font) still engraves as path.

Hi @wierd101
Thanks for the feedback. we’re fixing it now.
Will publish a beta first. keep you updated.

Are there any updates on this issue? Unfortunately other tasks have taken my time so I haven’t been able to personally just go check recently. Thanks for your work.


The latest Studio-1.1.13p3 already fixed this.
You may download it from our website or update within the app.

Laser seems to be working all right at least for me. Tried a few SVG files successfully yesterday. There is already a p4 however. What did that add @Cleo ?

1 Like

It fixed a bug of drawing (while drawing with p3, the end-effector mistakenly changes to the laser mode). So if you want to draw as well as engrave, please use p4. Sorry for the confusion.