Laser etching broken

Firmware Version: tried all combinations from 3.1.17 to 3.2.0 to 4.4.0
Operation System: Win 10
uArm Controlling Method: uArm Studio

Seriously guys, what were your engineers smoking when they wrote the software for this USD ~800 PoS Arm.

My uArm was working OK for the last two years on firmware 3.2.0. I never updated uArm studio, because I didn’t want to touch a more or less working environment. 3D print was working and Laser etching too. (well, besides the known quirks here and there)

Today I was preparing my uArm for a new owner, since the 3D printing is totally outdated. I finally clicked “upgrade” in the upgrade prompt of the uArm studio, and then hell broke lose.

You removed 3d printing… how nice of you! So I tried if at least laser etching still works, but nada.

So I upgraded firmware to the most recent 4.4.0 and things got even worse. the arm does not even have the “learn movements” functionality anymore.

wasted two hours of my life trying to migrate back to 3.2.0 and tried to figure out which ancient uArm studio version still works, even downgraded firmware to 3.1.17 and back again to 3.2.0 but the laser functionality is still broken. you cannot adjust the zero position of laser etching… the arm just does not move when fiddling with the zero position.

again back to latest version, and the problem here is (besides you removed 3d printing…jeeeez!!!) that the zero position slider works, but when the laser etching starts, the laser moves around just 1 cm above the zero position, where the laser beam is not focussed to actually burn anythign…

how can I fix this??

Hi, if you need 3D printing, please back to firmware 3.2.0.
For the laser function you need adjust the focus according to the user maunal.