Loud alarm after Firmware update

Just now getting the time to setup uArm Swift Pro that I purchased during the original funding campaign. I followed the instructions on doing the firmware update (except there are none for what to do with the Python file) through the Arduino interface (which I use very often with my 3d printers, and what I get is a horrible screech alarm, and no functions or buttons respond.

I guess what I am looking for at this point is a step by step on how to revert it back to the original firmware. Then I can incrementally update it until I find the issue.


Watch “uArm Swift Pro alarm error?” on YouTube

uArm Serial No.: (the No. at the bottom of each uArm reading “UARM-XXXXXXXXXX”)

Firmware Version: 3.2.0

Operation System: Win(7,8,9,10)/Mac/Linux

uArm Controlling Method: uArm Studio/uArm Play/Arduino/Python (Please specify the software/library version)

Hi, it seems that the firmware is not good. You could download firmware(.hex file) here: https://www.ufactory.cc/#/en/developer, and upload to uArm by xLoader.


Before reload the firmware, could you remove the USB cable and restart the uArm to check again?


I was able to reset it back with the hex and XLoader. But does that mean I can’t use the latest firmware?

I am able to get as far as 4.1.0 without the alarm…

Correction, at 4.1.0 it doesn’t move, then when I click stop, it jumps around like its stripping gears.

It appears I am stuck at 3.2.0…

Hi, the firmware 4.0 is design for developer, it dose not support some function of uArm Studio. We recommend you to flash the 3.2.0 firmware first.

Hi Daniel, are there any plans to make an official 4.0 firmware release? It’s very important for me, because such speed improvement is great (I need it for playing musical instruments), but the current unofficial 4.0 firmware works incorrectly (coordinates are very distorted). Thanks

I flashed to 3.2.0, but, anything after that just does not allow the machine to work. Is there anything I can do to get you information or specs of my machine to help get this solved? The speed improvement would be super helpful.

Lets please keep this thread focused on fixing my machine.

The issues with your machine are exactly the same as with mine, so, what is the problem?

Because you haven’t clarified ANYTHING except that you want to know if a release is coming because 4.0 beta doesn’t work. That’s the problem. But please, continue to hijack this thread so that the issue it was started for gets buried.

Maybe because this release should fix both our problems, or it is still not clear for you? This forum looks compact, so why flood with duplicates?

Hi, as the firmware 4.0 dose not support the 3D printing and sensors, we are not going to push it to consumers. If you do not need to use the 3D printing/Blockly function, you could try firmware 4.0(GitHub - uArm-Developer/SwiftProForArduino at Version_V4.0).

Hi, what happened after you flashed the firmware 3.2.0? Could you tell us more details by video?


Yes, I tried it but it works incorrectly. I hope you have plans to make the same speed improvements in the official firmware?

Thanks for your feedback, we will pass it to our software team.

1 Like

So is everyone with a Swift Pro on firmware 3.2.0?

Almost everyone, we do not push the firmware 4.0 on uarm studio.