"No uArm Port Found" under Ubuntu/Linux

I’m using theuArm Swift, and I’ve plugged it in to my computer via USB, but when I try and run, say, python -m pyuarm.tools.firmware -d, it says:

pyuarm - INFO - pyuarm version:
pyuarm - INFO - writing to /home/noon/uarm/assistant/firmware.hex, file size: 80486 bytes 
Downloading: [==================================================] 100.00%
pyuarm - ERROR - No uArm Port Found

and when I try and run python MainGUI.py it also doesn’t list devices.

how can I make the uArm appear as a device on my operating system? this is ubuntu:

Linux pac 4.4.0-75-generic #96-Ubuntu SMP Thu Apr 20 09:56:33 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

When I run

from serial.tools import list_ports
ports = list_ports.comports()
for p in ports:

the port that is related to the USB is this one:

USB VID:PID=2341:0042 SER=556323133383515041F0 LOCATION=1-1

but this does NOT match the expected port in the code (list_uarms.py):

USB VID:PID=0403:6001

nor is it the serial number on the bottom of my device.

interestingly, when i run a arduino (the software for writing to arduinos on linux), it DOES pick up the arduino on COM0. so I think the problem is that for some reason this hardcoded value in list_uarms.py is either not right, or my device is reporting the wrong value.

what should i do here?

okay, so it works under Mac with the latest version of the uArm studio

so i guess i just need a linux version?

i made it work just by switching this hardcoded id.


Sorry for the late reply.
We just uploaded uArm Studio (Swift) for Win10/Mac users last week.

For developers, we uploaded SwiftForArduino library.
BTW, the old libraries on our github page (libraries except SwiftForArduino) are only compatible with uArm Metal, our previous product.

This week we will upload uArm Studio(Swift Pro) for Win/Mac.

Our schedule is tight and we’re short of hands.
We have to prepare libraries for Swift & Swift Pro first before developing uArm Studio for Linux.

So it will be a while before uArm Studio(Linux) is available.
Sorry for that. :frowning:

Please use the uArm Studio(mac) or SwiftForArduino with your uArm Swift currently. Thank you so much.