uArm Studio for Linux

Is there an ETA on when we will have the uArm Studio available for download for linux?

As per my other thread - "No uArm Port Found" under Ubuntu/Linux - #4 by silky - I can’t actually get any of the opensource libraries on github to work with my uArm Swift :frowning:


Sorry for the late reply.
We just uploaded uArm Studio (Swift) for Win10/Mac users last week.

For developers, we uploaded SwiftForArduino library.
BTW, the old libraries on our github page (libraries except SwiftForArduino) are only compatible with uArm Metal, our previous product.

This week we will upload uArm Studio(Swift Pro) for Win/Mac.

Our schedule is tight and we’re short of hands.
We have to prepare libraries for Swift & Swift Pro first before developing uArm Studio for Linux.

So it will be a while before uArm Studio(Linux) is available.
Sorry for that. :frowning:

Please use the uArm Studio(win10/mac) or SwiftForArduino with your uArm Swift currently. Thank you so much.


This is terrible. I only run Linux.

Linux version of uArm Studio is already downloadable on our website.

I tried it on Ubuntu. It never detects the uArm. Also many menu options are broken and generate errors.

1 Like

Please report detailed info of the errors here: Customer Feedback Form

uArm Studio only works for uArm Swift & uArm Swift Pro.

Also tried running it with Windows 7 on a Virtual Machine. Windows 7 successfully connected and it shows in the device manager but uArm Studio does not detect it…
In both cases it shows up as a serial port.

Hi, please report detailed info of the errors here: Customer Feedback Form

This will help us locate the problems and deal with them. Thanks!

I forgot to mention that I did this.

I cannot run uArmStudio-prod-1.0.50.AppImage with tie following commands on my PC (ubuntu16.10).
Is there any other way to run it?


chmod a+x uArmStudio-prod-1.0.50.AppImage

Error Message:

Cannot open /tmp/.mount_DUWBvg/.DirIcon


Does the window launch at all?

No, the command ends with only leaving the error message.

Did you happen to run it with sudo at some point?

I figured my issue out. MUST add your user to dialout group and possibly add a rule for the /dev/ttyACM0 port to allow read/write access

Thank you for fast replying but still same result with sudo and dialout.

Is there any way to see more log?

I would check to see if that /tmp/.mount.... file exists. I assume that is removed after a reboot but IDK. My thoughts were that if you had launched it via sudo it may have created files that are not accessible when launching without sudo. AppImage format is weird to me. Try deleting it, downloading it again and the chmod +x and then run it again. I am on 17.04, I’m not sure if that made a difference for me or not.

Actually maybe better.

sudo mkdir /mnt/loop0
sudo mount -o loop uArmStudio.AppImage /mnt/loop0

You can now browse or copy the code from the AppImage. Seems there is some code blocking it from executing as is. Maybe a few lines, maybe not


Thanks for the information but I could not solve the problem by my self.

Today, I tried to print 3d object with using 2017-07-12 release version software and I succeeded in printing!
Thanks for fixing this problem!

1 Like