ROS catkin make


I am trying to use the Uarm with ROS for a undergraduate research; however, when I get to the step to create the catkin workspace, I get an error saying that it cannot find the cpp files. Any suggestions or other GitHub repositories to visit to get ROS working?


Can you post the exact error messages you’re seeing ?
Where did you clone the repository from ?
I have a ROS environment installed and under the src directory there is a single .cpp file:

I clone the git repo at: GitHub - uArm-Developer/UArmForROS: ROS packages for Metal

That’s the repo I am cloning as well; I am trying to follow the instructions on that site as well

A couple things to try:

-Source your ROS setup config file before trying the catkin_make:
source ~/catkin_ws/devel/setup.bash
source /opt/ros/$ROSDISTRO/setup.bash (replace $ROSDISTRO with whatever version of ROS is installed under /opt/ros)

-Check to make sure your CMAKE_PREFIX_PATH looks like this:

-Check to make sure you have packages like ros-indigo-roscpp installed.


Thanks! I’ll try that and get back to you.

Sure. Let me know how it goes. Since most of ROS code is either in C++ or Python, having catkin complain about roscpp or rospy means that your environment isn’t properly set up or there’s something very broken about your ROS or Ubuntu install. Like you don’t have g++ installed or something.

This worked! However, I am now getting the error, “package uarm not found” when I try to connect the uarm. Any suggestions?


Did it build correctly when you did the catkin_make ?

Which thing worked ?
Did you fix it with running the setup.bash script or was there a missing package ?

It built correctly with the catkin make; I’m using VBOX for importing linux so I think there was a problem with that. Still not sure why I can’t connect though.