Servo Error Code:17 Single-turn Encoder Error


I’ve been using xArm for about a year now.
Recently, while using xArm7, I’ve started to constantly encounter the servo error code:17.
Thinking it was a known issue, I looked into possible causes.
There were similar cases, but I believe this shouldn’t happen since I turn on the power almost every day.
Numerous restarts haven’t solved the issue, and even after updating the firmware to version 2.3.0 and trying various solutions, it still doesn’t work.
What actions should I take to resolve this?
Please give me some advice.

Additionally, I was wondering if there are any plans to reflect models with an ft-sensor in ROS?

Hi Shumpei,

Please follow the below steps to clear S17 error with status code16.

  1. press down E-stop button and then release
  2. enter into ‘Settings-General-Debugging Tools-Joint’, send ‘H101 D0104 V1 I5’ to unlock joint 5, manually move joint 5 a little bit, and then send ‘H101D0813V2I5’, press down E-stop button. (This step will reset the zero position, so you need to mark the original position of J5 before moving)
  3. release the E-stop button, move Joint 5 to the original position, send ‘D13 I5’, press down E-stop button.
  4. Try to enable the robot again.

Currently, we only reflect models with xArm gripper in ROS, and no plan to add other models.

Best regards,

Hi Minna,

Thank you for your advice.
Following the steps you provided, the error was resolved, and I was able to get it moving again successfully.

It was a great help.


We are facing a problem in starting the xarm lite 6 model, after connecting it to the power and enabling it, it’s throwing a servo error. Status code: 16, code: S17, joint ID: 3. What should be done to correct it?

Hi Vinod,

You can follow the steps above. But you need to modify the command to clear the error for joint3.

I*, * stands for the joint ID:
H101D0104V1I5 → H101D0104V1I3
H101D0813V2I5 → H101D0813V2I3
D13 I5-> D13 I3

Best regards,

we are facing a problem with the Controller Error code : C22
self-collision Error
have tried to change the initial position by manually and we have set some position as initial position
when we recorded manually running in between this error code C22 is getting can you help me

Hi Vinod,

Have you reset the zero position of any joint by sending ‘D13 I*’? Please move the arm to the zero position(0° for each joint), take a photo, and shoot a video of C22 error to,
can we have a quick video to troubleshoot the problem?

Best regards,