The pump stops working

Your uArm Serial No.: (the No. at the bottom of each uArm reading “UARM-0309160103”)

Your Firmware Version: 2.2.1

Your Operation System: Win(8)

Sometimes the pump stops working when i use it, and is re-operational after 2-3 minutes, is this normal ?
(Maybe because it’s too hot ?)

Thanks !

Contact Us:
English Channel

What software were you using when this problem occured?
uClient, UCS or Coding in Arduino/Python?

It occured one time with uclient and one time with UCS, I tried to unplug and plug the usb cable but It didn’t do anything, each time I have to wait some minutes until the pump re works.

It might be because the tube is “blocked” somewhere. (as is shown in the pic)

Thanks for your answer (I will see when it will happen) but I’m not sure that it’s that because the pump doesn’t start when the problem occures, the pump doesn’t produce any sounds, I just heard the “click” of the valve :slight_smile:

The problem just happened now, the tube is not blocked, it worked fine but suddenly the pump stoped working. When I click on catch in Uclient, the pump doesn’t start, I can just heard a click but not the noise of the pump.
It happened after only 5 minutes of utilisation.
I unplugged and replugged the alimentation of uarm and it didn’t work.
I waited 10 minute and it was always not working, I tried to move the pump’s cables and It worked !
It seems that there is a faulty connection in the pump block …

It’s annoying because every 5 minutes I have to shake this part of uarm if I want the pump to work …

Hi, this is a connection problem caused by the cable.

Please PM me your mailing address and we’ll send you a new cable.