U arm Pro doesn't connect to Uarm studio

Hi My Uarm Pro doenst conect to uarm studio. not on mac an not on PC. tried diverent cables… diverent ports restarts. new install.

app on iphone works

uArm Serial No.: UP130018040687

Firmware Version: ? doenst connect how can i see this. were can i download new version. how to install.
did a firmware update! with this link [Official] Manual Firmware Upgrade (uArm Swift Pro)
Operation System: Win 10 and mac os
uArm Controlling Method: uArmStudio-x64-prod-1.1.19

“Studio”: {
“APP_NAME”: “uArmStudio”,
“APP_VERSION”: “1.1.19”,
“Channel”: “prod”,
“CATEGORY”: “software”,
“LANG”: “en”,
“OS_INFO”: “win32 x64 10.0.17134”,
“OS_TYPE”: “win”,
“OS_ARCH”: “x64”,
“MAIN_WINDOW_URL”: “file://C:\Program Files\uArmStudio\resources\app.asar\dist/index.html”,
“FAQ_URL”: “http://issue.ufactory.cc/faq.html”,
“HOME_PAGE_URL”: “http://ufactory.cc”,
“forum”: “https://forum.ufactory.cc”,
“github”: “UFACTORY · GitHub”,
“facebook”: “uArm Robotic Arm User Group | Facebook
“UPDATE_URL”: “http://update.ufactory.cc/releases/updates.json”,
“FIRMWARE_DEFAULT_DIR_PATH”: “C:\Program Files\uArmStudio\resources\studio\firmwareDefault”,
“UARM_CORE_PATH”: “C:\Program Files\uArmStudio\resources\studio\uarmcore”,
“UARM_VISION_PAH”: “C:\Program Files\uArmStudio\resources\studio\uarmvision”,
“UARM_CORE_VERSION”: " 1.0.1",
“STUDIO_DIR_PATH”: “C:\Users\eric\uarm\studio”,
“HOME_DIR_PATH”: “C:\Users\eric\uarm”,
“STUDIO_CONFIG_PATH”: “C:\Users\eric\uarm\studio\config.json”,
“FIRMWARE_DIR_PATH”: “C:\Users\eric\uarm\firmware”,
“AVRDUDE_DIR_PATH”: “C:\Program Files\uArmStudio\resources\studio\avrdude”,
“LOG_DIR_PATH”: “C:\Users\eric\uarm\studio\log”,
“DRIVER_DIR_PATH”: “C:\Program Files\uArmStudio\resources\studio\driver”,
“CURA_DIR_PATH”: “C:\Program Files\CuraForuArm\Cura.exe”,
“CACHE_DIR_PATH”: “C:\Users\eric\AppData\Roaming\uarmStudio”,
“API_HOST_URL”: “http://studio.avosapps.us/
“UArm”: {
“portName”: null,
“firmwareVersion”: null,
“hardwareVersion”: null,
“productName”: null,
“productType”: null,
“portSerialNumber”: null,
“currentX”: null,
“currentY”: null,
“currentZ”: null,
“currentR”: null
“Problems”: {
“coreExisted”: true,
“coreRunning”: true,
“coreConnected”: true,
“uarmConnected”: false,
“driverInstalled”: true,
“uarmPortConnected”: false,
“other”: “”
“ports”: []

Hi, it seems that the uArm failed to communicate with the PC, could you find the Arduino Mega 2560 on device manager while connect the uArm to the PC and power on?

Hey, I got the same problem. I am using WIN10 and I can find Aruino Mega 2560 on device manager. But couldn’t get it connected to uArm Studio

I tried different usb cables and now it works

Did the uarmcore run? You could check it on the task manager, if not, you could run it manually( refer to 11 of this post)

How to run uarmcore manually?

Hi Liu,

What is the OS version of your PC? What is the problem?
Can you find Arduino Mega 2560 when connecting the uArm?

Best regards,