uarm_calibration.cpp class issue

hello, i was trying to do calibration, but there is an compiling error:

/home/ka/Documents/libraries/UArmForArduino/uarm_calibration.cpp: In member function ‘void CalibrationClass::cleanEEPROM()’:
/home/ka/Documents/libraries/UArmForArduino/uarm_calibration.cpp:124:26: error: ‘class EEPROMClass’ has no member named ‘length’
for(int p = 0; p < EEPROM.length();p++)

I wonder why this is happening? did i miss anything here?

Thanks a lot!

Hmm… Well, my Arduino library version of EEPROM.h from 2006 certainly has the length() member.

This page from the Arduino forum:

says that IDE versions prior to 1.6.2 do not support length(). Could that be it?

Otherwise, my next guess is that you may have an updated/3rd-party EEPROM library that is being loaded instead?

It got even worse here: tried to use the UArm library in (a completely stock version of) Arduino 1.7.10 and now EEPROM no longer has the “get” member…

Any suggestions how to get around this?

Hi @WaldoPepper, I tried v1.6.8, It’s working. You could refer this link for EEPROMGet. I also replied you at Github Issue.