uArm for ROS while connecting

I am trying to use uARM with ROS. I have installed the libraries as instructed.
But when I run the following command
rosrun uarm connect /dev/ttyUSB0

The terminal keep showing ‘Connecting’ and I can’t continue. Is there any solution for it? Thanks.

I am not familiar with the ROS use of uArm, but it appears as though your system cannot find the USB connection to the uArm.

Have you downloaded the FTDI driver from this website? It is needed for the uArm’s connection to work.

If that page looks new to you, installing the FTDI driver will probably address your issue.

It seems that it is not the problem with FTDI driver. The reasons are:

  1. when I check the usblist, I can see that the uarm is in the connection list.
  2. when i check the connection with the serial monitor and i can see that the PC can communicate with uarm.

The problem is probably due to the Arduino stretch for communicating with ROS is missing. I find one here:

But it seems that it is not for the uArm Metal. Is there any such stretch for uArm Metal? Thanks.

It seems that you are correct.

The only additional information I can provide is that the last time I heard from Joey Song (lead developer), they were hard at work on some extensions to the firmware for ROS.

Hi DCorboy,

It seems that FIRMATA-EEPROM-StandardFirmataEEPROM.ino plays the function of uArmROS.ino to communicate with ROS. It works!

@Shan_Luo and @DCorboy

Hi Guys,

Quick questions if you don’t mind: can uArmForROS be used for features other than the control and monitor nodes in RViZ? such as writing and running scripting trajectories through ROS?

Do you have any knowledge of the additional firmware for ROS that is currently being worked on?


I am getting the same error as you; could you go into more detail of how you resolved this issue?