uArm inconsistent movement, locked servos, and firmware failures

uArm Serial No.: (the No. at the bottom of each uArm reading “UARM-XXXXXXXXXX”)

Firmware Version: 2.2.1

Operation System: Ubuntu 14.04

uArm Controlling Method: Arduino/Python (pyuarm

I’ve been having a ton of problems with the uArm. I tried controlling with the pyuarm library but movement was always sporadic and inconsistent. When doing relative movements, for example, the arm sometimes would move and sometimes wouldn’t move. When setting absolute positions, it would move to different locations even if I put in the same coordinates. When moving just x and y coordinates, the arm would move in the z-axis anyways.

I recently tried using the Arduino library and was having more luck with it. Movement was a bit more consistent although sometimes it will still not move (e.g. if I tell it to move relative x:-10, y:10, z:0, it will just not move). And moving just x and y would still result in z-axis movement occasionally.

I was experimenting more but now the uArm will not move at all. It will wiggle a bit when I plug it in but otherwise all the servos are locked.

I thought I may need to detach them programmatically, so I re-flashed the 2.2.1 firmware. The uArm assistant said it was successfully flashed and detected the 2.2.1 firmware.

Then when I use pyuarm to connect to it, I get this error:

UArmConnectException: 'Unknown Firmware Version-@1message received timeout.'

When I re-open the uArm assistant, suddenly the detected firmware is “Unknown”.

I’ve tried this again several times but it still will not work.

What’s going on?

uArm User Facebook Group
Contact Us:
English Channel

also I was just letting the arm sit there without moving and the left servo started overheating.


The pyuarm is in the dev branch of our github, which is still under development and unstable.

Please use the one on the master branch.
You can install by entering command line:
pip install pyuarm --no-cache-dir

We’ll fix this bug and publish a new pyuarm library on the dev branch on our github next week.
The new library will be compatible only with Python 3.x
Sorry for the trouble.