UArm Metal ahowing up as Silicon Labs USB to UART but I am not able to upload sketches

I just bought a new UArm Metal at Maker Faire. Initially I did not see the UArm at all but after some digging I found that it was showing as a Silicon Labs USB to UART converter. I installed the manufacturers drive and the port is now available in Arduino.

That said I cannot successfully upload the Calibration sketch.

I keep getting the following error:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

I have tried the fixes suggested elsewhere in the forum namely to repeatedly try the reset button and upload buttons.

I can see the Rx light blink when I attempt an upload or to send command via serial from Python.

I am at a loss as to what is wrong.

For what its worth the MCU is labelled as v3.1. Also fiddling with the four buttons on the back yield mostly small twitches and chattering sounds or the occasional programmed movement. I am begging to suspect that the MCU may be faulty.

You’ve tried using the UART driver listed on the downloads page?

Yes I have, but it was not showing up with the FTDI VCP drivers.

I am running OS X 10.10 and have also tried the suggested fixes for the conflict with the native FTDI driver clone. These fixes did not work.

Only when I installed the Silicon Labs CP201X drivers, based on information from the ioreg command, did the UArm port show up.

Ah yes, OSX. I had a similar problem, but the standard fixes worked for me.

FWIW, for me on OSX, the driver does not show up as anything but one of those intelligible USB connections and I just choose the one that appears when I connect the uArm. :slight_smile:

Sorry that I could not be of more help.

I think part of the issue is that I have one of the newest models with the UFactory made s-bus type servos and integrated board with MCU. The documentation I can find on the UFactory site does not cover this unit.

I can use screen to communicate with the UArm at least in so far as I get a welcome message on reset and messages when I activate learning or replay. I get no response to sent commands other than command not recognized or freezing. This later happens when I try MOVE 0 0 0 0.

I have the integrated MCU model as well and haven’t seen the issue you describe. I am wondering now if I recall of some interaction issues with FTDI and OSX.

You might try looking for more interaction problem reports and (possible) solutions like this one:

My first troubleshooting attempts were for issues with OS X and the FTDI drivers; which is how I found that this unit is not using the FTDI chip but rather a Silicon Labs/Cygnal CP210X chip. I was only able to communicate at all with the unit after I installed the Silicon Labs drivers.

What is the version number of your control board? Mine claims to be v3.1 and has a different layout than the one pictured in the UArm Metal User Guide.