uArm Metal; not working using Arduino

Hi there,

I just got the uArm and it has been working fine using the uClient, but I haven’t managed to make it move using GettingStarted.ino from the Arduino API. I have tried calibrating using the Calibration.ino from the same API, but uArm does not move during the process and I get the following:

intercept_address: 70
slope_address: 50
servo 0
intercept_address: 70
slope_address: 50
servo 1
intercept_address: 70
slope_address: 50
servo 2
intercept_address: 70
slope_address: 50
servo 3
Put uarm in calibration posture (servo 1 to 3: 45, 130, 20 degree respectively), then input 1
Offsets for servo 1 to 3 are -135.92
Save offset done!
All done!

After that, the servos remain detached. I have tried to reinstall the firmware (same version that has been working until now) and use the uClient, but now the uArm is unresponsive.

Any ideas how to make uArm work again after using Arduino API?

Many thanks,

I have managed to calibrate it with python API and now it works using the uClient. I also can get current coordinates with both Arduino and Python APIs, but I still can not make it move; neither using Arduino nor Python “uarm.moveTo”

Any ideas?

Hi @Ferran, Would you tell us which version of uArm you are using ? and the arduino firmware version and python library version.

Hi Alex, thanks for your reply but uArm is already up and running. I don’t really now how I fixed it but I did.

Hey Ferran, I’m having the exact problem, im in a real hurry, could you give me any clue to solve it?
also, @Alex ?

Im using uArm Metal, got it this week. I’m trying to find solutions, but seems all the links are down, and the web doesnt work properly.

Also i tried to follow the steps on this post “[Official] uArm Metal Calibration Guide” so I enter to this link:

And then at this point: “Notice Please make sure you install the uArm cli before. please refer uArm CLI”
the uArm CLI link DOESNT WORK

Im really pissed to be honest

I even tried Download UCS V1.2.2
This thing uploaded to the last firmware, and tried to run the uArm_client v2.0, BUT it isnt working properly

All i want to do is, calibrate it with ARDUINO(or any other way), and program it using arduino(And yes i know how arduinos works…) if possible and pls if u send me to THIS LINK:

Make sure to explain me how to DO THIS STEP:
“You need to recalibrate when you are new to this library. we recommend the GUI Calibration tool.”

Hope I can get a usefull answer. Thank You

Bump. @Alex @Ferran

Simple question: How do you calibrate via Arduino? I don’t expect direct support from open source products, but missing important information and dead links from uFactory is making uArm abysmal to work with.


sorry for the troubles.

We’re now updating firmware and caused some problems at this time.

Please use the Arduino library here:

Since the new firmware is not on official website now, we haven’t publish the new library yet.

I had the samre problem, you will have to recalibrate it using the new arduino library, but they are still writting the new calibration guide…so it seems we will have to wait.