uArm Pro - Jerking/clunky motion


My uArm Pro is making clunking noises and jerking while trying to move. I have uploaded in unlisted video to youtube.

Please advise of how I can fix this. I am happy to diagnose further with instructions.


uArm Serial No.: (the No. at the bottom of each uArm reading “UARM-0505170307”)

Firmware Version: 3.1.9

Operation System: Win10

uArm Controlling Method: uClient (uArm Studio V1.1.12)

Please double check the connection of the arm, the picture might help, thanks

Hi Tony,

I have tried unplugging and plugging in all of those connectors. I have also tried another power supply, tried it with the laser, the suction and with no attachment. It has the same problem with any combination.


Ok that sgould be the hardware problem. I would send a new one to you, sorry for the inconvenient.

OK. Thanks Tony.


I’ve just started using the uarm swift pro, and I have the same problem. What can I do?

Hi,please check the image sent by Tony, if it’s not working, please contact to send your product to repair.

1 Like

Thanks for the response, I contacted support!

Is that issue solved?

Nog really.

I keep getting strange e-mail from the address you mentioned earlier.

No real replies.

Could you PM me your Email address?

Yes, how?

Hi, click the Icon of my name and send Message. Thanks


Is what I get to see. No options for sending message.