uArm Takes Several Seconds to Respond to Commands

As the title says, the uArm Swift Pro takes several seconds to process and respond to commands. For example, when just using the “Control” tab in uArm Studio, it can take from about 5 up to 7 seconds for the robot to move to a location after the location is specified. Blockly and Teach and Play both have the same problem. I also tried to control it via the Python library, and it had the same problem as before.

I tried unplugging, powering off, and rebooting uArm Studio, but the problem persisted. On a hunch, I tried downgrading the firmware version to 3.2.0 and that fixed the problem temporarily. While in version 3.2.0, the robot behaves as normal. I decided to then update the firmware to 4.3.2 again, and I was met with the same problem.

However. However, after powering it off for a short period (~10 minutes), I once again turned it on, and it was completely fine. I thought that maybe it was fine fore good and there was just a glitch, but after leaving the robot unplugged overnight, I came back and it was back to the sluggishness and non-responsiveness.

Temporarily, I left the robot in firmware 3.2.0, but I’d like to figure out what is causing this.


uArm Serial No.: (the No. at the bottom of each uArm reading “UARM-0CB2B77BE6BD”)

Firmware Version: 4.3.2

Operation System: Windows 10

uArm Controlling Method: uArm Studio 1.1.21 (Teach and Play, Control, and Blockly)



Hi, could you shoot a video about that issue when the firmware is 4.3.2? Thanks

Thanks for getting back to me so quickly. Unfortunately, I forgot to record the robot having this since I was in a rush, and now it appears to be working fine with no issues. I know that I didn’t imagine the whole thing, because other people saw it too. I’ll post here later if it happens again, but for now, everything is working fine.

Oh, OK. If it happen agian, please shoot a video and share to us. Thanks

The bug has resurfaced. Here’s a short video of it in action. All we are doing is attempting to control the robot via the uArm Studio. It was doing the same thing with the Python SDK, but this is a much easier way to see the delay.

Hi, just want to confirm

  1. the uArm in the video is under firmware 4.3.2.
  2. The uArm Studio is V1.1.21 for Mac
  3. You control the uArm by uArm Studio(for Mac), no other devices connected to uArm or send command to uArm.


  1. uArm is under firmware 4.3.2
  2. uArmStudio version is V1.1.21 for Windows
  3. The only device plugged into the uArm is the Windows 10 Laptop shown in the video.

What happend if you send Gcode(by Arduino IDE) to control the uArm by the same PC?