uClient not working on Mac

Hi, I’ve tried uClient on my Mac and it is not working at all. Everything is set up properly since I can use uArm class in my Python file.

I am using a Metal uArm.

I’ve tried it in Windows and the only one working is the 32b version as neither the 64 works. As I am not the only one having this problem apparently do you have any solutions? Any new software coming?


Hi, please download the beta version of our new software UCS by clicking the link below:
The installation pack includes:

  • the latest firmwareV2.2.1 (not released on official website yet)
  • the latest uClientV2.0 (the current uClient on our website is NOT compatible with the latest firmware)
  • uArm Creator Studio (both a VPL and an IDE)

Hi Cleo, I’ve tried to run uClient2.0 on my mac, but I get the same problem I used to get for the previous version. This is what I’ve when I run the new version of uClient.

Regarding the firmware, I don’t know why I am not able to upgrade to the new version.

(cv3) Luca:~ lucadigiammarino$ uarm-firmware -u Fetching the latest firmware version... Traceback (most recent call last): File "/usr/local/bin/uarm-firmware", line 9, in <module> load_entry_point('pyuarm==1.3.34', 'console_scripts', 'uarm-firmware')() File "/Library/Python/2.7/site-packages/pyuarm/tools/firmware_helper.py", line 314, in main helper.upgrade() File "/Library/Python/2.7/site-packages/pyuarm/tools/firmware_helper.py", line 201, in upgrade if self.compare_version(): File "/Library/Python/2.7/site-packages/pyuarm/tools/firmware_helper.py", line 195, in compare_version self.remote_firmware_version = get_latest_version() File "/Library/Python/2.7/site-packages/pyuarm/tools/firmware_helper.py", line 47, in get_latest_version config.readfp(buf) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/ConfigParser.py", line 324, in readfp self._read(fp, filename) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/ConfigParser.py", line 512, in _read raise MissingSectionHeaderError(fpname, lineno, line) ConfigParser.MissingSectionHeaderError: File contains no section headers. file: <???>, line: 1 u'<?xml version="1.0" encoding="UTF-8"?>\n'

I’ve tried to upgrade the firmware from the file in the folder just downloaded, but I get this

/Users/lucadigiammarino/Downloads/ucs_v1.2.2/firmware/flash_firmware ; exit; Luca:~ lucadigiammarino$ /Users/lucadigiammarino/Downloads/ucs_v1.2.2/firmware/flash_firmware ; exit; Illegal instruction: 4 logout

Hope you can help


Sorry for the late reply.
Please flash your firmware again via uArm Assistant.
PM me if you encounter any further problem.

Hi Cleo, I’ve flashed the firmware again from uArm assistant and it seems to work.

However, regarding the uClient, I am still receiving the same issues. Same grey screen on my mac. Please let me know asap. I have jdk and jre installed on my machine.


sorry for the late reply!
Did you use the latest uClient 2.0 downloaded from our official website?

also, please let me know the version of your MacOS.

I checked the info@ufactory.cc and didn’t see your email.
Which address did you email to?

Now that I know your info I’ll deal with the problem immediately.

I’ve sent you an email including all the steps of possible solution and the files you might need to this address: lucadigiammarino2@gmail.com
But the email is rejected by host.

Do you have another email?

lucadigiammarino2@gmail.com is correct, I keep receiving emails and it is very weird that is rejected.


These are two additional email addresses

I’ve re-sent the email to both email address.
Let me know if you didn’t receive it. Thanks.

hi cleo, I just bought the uArm and nether the uarm client or the assistant are working on my mac sierra os. it only says that the uarm asistant cant be oppened

Please PM me screenshots about the problem you’ve encountered, thanks.