Unable to Update Firmware in Windows 10 Using uArm Studio

uArm Serial No.: D43639DF8919

Firmware Version: 3.1.27

Operation System: Win10

uArm Controlling Method: uArm Studio (version 1.1.20)

I just unpacked my uArm Swift Pro. The Offline learning works just fine. But, when I run uArm Studio, I get a message that says “Please update firmware to continue. *uArm Studio(v1.1.20) is only compatible with Firmware v3.2.0 or after. Please Update now.”

When I click on Update Now, it takes me to an Updates tab where I can update to either Firmware 3.2.0 or New Firmware 4.3.2. However, in either case, when I click on it, I get a brief message that “USB Plug Out” and the software freezes up showing it is 0% updated.

The USB plug is in, and on the Device tab, I can see the Device Information.On the Troubleshooting Tab, under Inspection, it says that “Everything is working fine!”

In Device Manager on the PC, it shows that I am connected to an Arduino Mega 2560 on COM 11.

So, do you know why it might be failing to update?


Please disable the software (e.g. Arduino IDE and/or uArm Studio), if you did use the uArm Studio, please open the “Task Manager” (Ctrl+Shift+Esc) and make sure that the “uarmcore” process was terminated.
And then try to flash the firmware by xLoader again.

​Thank you - I did this and it did not help. I even tried it on a different computer that didn’t have the uArm Studio installed on it to eliminate that variable and also to make sure it was not a hardware issue with the laptop.

One other thing I have found: if I do connect to the arm with a serial window, I am able to control the arm using g-code commands. If I then start uArm Studio, it recognizes that it cannot connect, and as soon as I close the serial window, uArm Studio will connect. But, it still will not allow me to update the firmware.

Thoughts for other things I should try? Is there an earlier version of uArm Studio available somewhere that would work with my firmware (3.1.27)?



Could you shoot a video of this issue and post here, it may help us to figure out the problem.


I have updated two videas - Part 1 (https://youtu.be/RpNdZ45hF-0) and Part 2 (https://youtu.be/MneZOqVHceM).

In the first video, I start with a laptop that has just been restarted, so nothing should be running. I run the FirmwareFlash Tool, and it fails. I then run the uArm Studio program to show that it can see the arm on COM11 and communicate with it, but it also cannot flash the firmware.

In Part 2, I have killed the uArm Studio program and all processes. I then connect to the arm using a serial monitor in the Arduino IDE and send it g-code commands, and the arm responds.

So, I know I am connected successfully with the arm and I can control the arm with g-code commands, but I cannot update the firmware in order to be able to use the uArm Studio software.

Thanks for your help,


Any thoughts on this? Thanks!

How about try to use the xloader to flash the “uArmSwiftPro_Standard”, please make sure that uArm Studio/uarm core or Arduino IDE was terminated before you flash the firmware, or it will say prot busy.
Here is the download link:

This did not work for me either, unfortunately. I did obtain another Mega 2560 board for troubleshooting purposes, and I was able to flash firmware to this board using the FirmwareFlash Tool. This leads me to suspect a hardware problem. I am thinking of taking the bottom off of the uArm Swift Pro to see if I can swap out the Mega 2560 board. Do you know how difficult this is, and are there any instructions going over what I would need to do?



Hi Steve, the another Mega 2560 is the same type for uArm Swift Pro? If so I can send you an instruction to replace the baord, please set me a personal message to let me know your Email address.


Thanks, Daniel - how do I send a personal message?

You could send an Email to me directly, my work Email is daniel.wang@ufactory.cc