Update 3.1.17 won't aply

uArm Serial No.: (the No. at the bottom of each uArm reading “UARM-XXXXXXXXXX”)

Firmware Version: 3.1.16

Operation System: Win(7,8,9,10)/Mac/Linux : w10

uArm Controlling Method: uArm Studio

Update 3.1.17 won’t apply.

Still says that the firmware version is 3.1.16 and Temp prob is not fixed.



Official Store
uArm User Facebook Group

English Channel

update of uarm studio was done but the update still fails

me too. update of uarm studio was done but the update still fails

Likewise… 3.1.17 goes through the motions, but still says 3.1.16 afterwards…

The firmware hex file is now there

and I managed to do the firmware update with the flash tool here :slight_smile:

and that did fix the temp issue

Hi @max75 @fandy_G @anthonyw

We reproduced the problem and are now fixing it.
Will let you know when it’s resolved ASAP.

Sorry for the inconvenience.


The problem is solved. Please update firmware again. Thanks.

I had the same issue, for me it worked switching back to an older uArm Studio version and updating the uArm FW before updating the uArmStudio

Same problem, I updated to the new firmware and the arm will not move.

Very troubling. Seems like V17 of firmware is not comparable.

How do I fix this?

Thanks you…

It won’t let me update. Wht do I do?

Download the firmware hex file there

and do the firmware update with the flash tool here

The address for the hex file is a 404.

Now it stops at 34% Flash and then times out.
What next?

It does not seem to be solved. Would you pleae provide steps to correct the issue?
Thank you.

try this one Releases · uArm-Developer/SwiftProForArduino · GitHub

Sorry but its the same problem. When I use the “Flash tool”, it gets to 34 percent and then times out.

Finally got it to update with he V17 hex file but the arm still will not move. It shows that its connected, but will not execute and moves. Very frustrating.

@Richard_Siderits @FeKo
So sorry for the problem. Please send me these two files:

  1. Go to Menu bar - Help - “Troubleshooting”, click download report and give me the report.
  2. Go to Menu bar - help- Open home folder, compress the whole “log” folder and send it to me.

I’ll PM you my email. Thanks so much.

Did you update successfully in Studio?