Vector Graphics for Laser


is there a way to use own vector graphics (svg, eps or anthing else) in uArm Studio - instead of using built in converter for jpeg?

or is there an alternative software which might control the uArm Pro with using vector graphics?

Btw.: very cool product!


1 Like

Yes yes yes!

I’ve also had great difficulty with using images in uArmStudio. Transparency definitely messes it up, and lots of “loaded” images seem to not show in the UI at all.

This halftoned rectangle, for example:

Hi @thecoda @crazyalex you can import svg files in Draw/laser


@Cleo thanks for your reply. I tried to import SVG into, but it doesn’t work.

I tried an SVG (link below), drawing a simple rectangle. I tried drag & drop and the “add image” button at the draw/laser section. I even tried different formats of SVG (1.0 to 1.2).

How to import the SVG file?

Here’s one of the SVG-Files is used:


Hi @crazyalex

We figured out the problem.
The svg file got processed by Studio so it was unable to show.
For the next version of Studio, we added a “vector” option so the imported svg file will not get processed by the “outline/black & white” function.

Sorry for the trouble.

@Cleo thanks again!

very cool, is it already available in the studio beta or should i wait until the final will be released? (when will it be?)


The beta will be release today! The final will be published one or two days later.

Nope. That sample.svg doesn`t show with studio#-p2. Nor does any other that I tried.

Some more thinking to do, too late for now…
EDIT: So here is my findings… Using: 1.1.13-p2
It seems that if a .svg file drawing has a very thin line, it disappears, and doesnt show in uArmStudio at all when imported as vector graphics (only option). Also if size of the drawing object is small, it doesnt show. I created a rectangle with a size of 15x4 cm, exported it as .SVG (in LibreOffice Draw), with line thickness about 5mm. Only then that picture appeared visible in Studio. I guess the problem arises from the fact that Studio scales everything down to some size???, that fits in between lines like B and C. If original line thickness is too thin, it disappears completely. In my case 5mm line scaled down to abt. 1,2-1,3mm. If this is true, a 1mm line would go down to 0,25-0,3mm, or smaller.
Now here is a test result: Anything smaller than 3mm in my drawing, wont give printout. It shows as a very thin hairline in studio, but laser doesnt start. A 3mm line scales down to 0,4-0,5mm, only then the pattern is somewhat like as in the original draving (15x4cm, line thickness 3mm). 3mm scales down to 0,4-0,5mm means that it is 1/6 of the original thickness.

The fact that Studio treats <3mm hairlines as flys shit, it wont show or print it at all… Correct me if if I am wrong!

And still this vector graphics file is treated as B/W graphics file, it`s drawn line by line, and each line has a gap to the next one. I would like to see a way to burn inline drawings, not just grabby graphics!

OK, Using 1.1.13-p3 (current beta).

Was able to import vector files (svg) and get the uArm to engrave to these lines in a continuous motion (no rasterizing). This worked well for loops or sections that were very close to being loops. They did not have to be basic curves or straight lines - spline curves or polylines imported from AutoCAD via Inkscape worked just as well. I was unable to import more complex spline curves into Inkscape to convert them, but i imagine if they had worked most of my problems would have been solved.

For non complete loops, the ends of the lines are connected with a straight line. This applied to all feature types that i tried:

  • Start and finish of a spiral were connected, as were ends of a medium complex set of partial ellipses connected by circular curves.

  • Ends of a semi-circle, when not connected, will join with straight line - example

Connected as a polyline:

Imported as separate lines

This is not so much of an issue for simple curves, but there are a couple of projects that i would like to do that would require more detail and can’t have connecting lines.

A second issue, is the scaling. All objects imported are auto scaled to fit. I would much rather the ability to manually scale the objects, ensuring a dimensionally accurate output. Once the software is able to import DXF files directly (hoping sooner rather than later), this will be very important.

Hi @Zotzot
In studio-p2, if you imported an image and choose the “vector” section. The file won’t get processed in B&W. But uArm will engrave in a B&W way. We already fixed this issue and uploaded a beta version of studio-1.1.13p3.

Could you share the picture that you use to engrave? So we can test it and figure out the problem.


Studio doesn’t do auto-scaling. When you import an image, it will set the width to a fixed value but keep the scale the same.
About connecting lines, we’ll test it today and figured out the problem.
Thanks for your feedback.

OK, now witth studio-p3 uArm does the job.Thx.

1 Like

When will the connecting lines issue be fixed? I’m still having trouble with it

Hi, what’s your issue?

When engraving an svg file in outline mode, the laser insists on closing every path, even when they’re not closed in the actual svg file. It also retraces every straight line that isn’t part of a path.

I’ve got the same problems. It even occurs with the includes graphics.

I opened a new thread: