What is the M2500 Command?

I’m a high school student and we got a uArm swift pro for our engineering club.We have tried to get the Open MV camera working but we don’t know what this M2500 command is. We’ve also look online but we still can’t find it anywhere.Could someone help.

Official Store
uArm User Facebook Group

English Channel

You’ll have to download the Arduino IDE to enter that command into it’s console

We arlready have the arduino ide but the problem is that we don’t know if the M2500 command is an example code on arduino, in which case we can’t find it, or if the M2500 command is code you create yourself in which case we can’t create it.

Hi, M2500 is the command of switching the UART from #0 to #1, so that the openmv could do the communication with robot arm. And it is also included in the quick start guide.

So to send the M2500 command I would type #n M2500/n on the arduino ide then upload it to the uarm?

Exactly, #0 M2500 or M2500 only. Both of them works, and please pay attention to the setting of monitor first. You could find more details in the guide. Thanks

Would I need to use a g-code interpreter like grbl to send the M2500 Command.

We just need a serial tool to send the command, no interpreter needed. Serial monitor of Arduino IDE is the best choice.

We have tried that so many times but it does not work. We have the uArm swift pro arduino library. Another problem is that now the uArm is not connecting properly to uArm studio. If we send commands on blockly noting happens. I think us trying to send the M2500 command the wrong way has upset the uArm. Does anyone now how to fix this.

The thing we did wrong was that we tried to send the command in the arduino IDE and not the serial monitor, and one time when we tried to send the 2500 command by the IDE and opened the serial monitor it displayed all the echo stuff that it should do like echo: Home offset . But nothing happened and now we can’t control the uArm.

I think if you record a video for us, it would help a lot. BTW, the M2500 command would switch the UART immediately which means after the command the USB port cannot get information any more( for more detail please check the developer guide). Only power on the arm again would bring it back. So if you get trouble with the connection, please try to unplug both the USB and power adapter, then plug them again and it should work. Thanks

I’ll have to what on till the weekend before I can send a video. But is there a way to factory reset the uArm or a way to switch the Uart port back to #0

The Pc knows the uArm is there bit it can’t tell what type it is. We can’t send any code to the uArm, so blockly, Drawing and 3d printing don’t work. The teach and play function does not work as well. When we power on the uArm swift pro the servos don’t lock like they should. So we think the uArm has problems communicating.

Uploading… This error comes up when we try to connect the uArm to the PC.

This is what comes up “object Object”

Hi there, I think you might upload the Arduino example code to the arm by mistake. Please try to flash the firmware to your arm and then have a try again. Here is the link: https://drive.google.com/open?id=0B-L-tCvknXU9dDhfSGJwT1JDY1U
When you are using the arduino IDE, please be careful, do not upload any code to the arm since it will over write the firmware inside of the arm. Thanks

Flashing the firmware worked and the uarm is back to normal so thanks.

1 Like

Glad to hear that :slight_smile: