Wrist keeps spontaneously turning

uArm Serial No.: (the No. at the bottom of each uArm reading “UARM-XXXXXXXXXX”)

Firmware Version: 1.1.14-p1

Operation System: Win10

uArm Controlling Method: uArm Studio

I am using this sequence to dip a substrate in different beakers of solution repeatedly.

It worked for me perfectly once. Now, however, when I run it, the wrist starts rotating by small increments every time the arm moves vertically. So right after the arm lowers, the wrist turns to the left, then when it raises up it turns to the left some more. Eventually it winds up all the way at 180 degrees. Even having the wrist reset and using the reset block doesn’t help. I’ve closed the software and restarted it, and it keeps doing this.

It seems to be something other than my code. When I create a “move to” block, the arm goes limp and lets you position it where you want. During this time, if I move the arm up and down, the wrist will start rotating (towards 180 degrees and actually even past the 180 degree mark, further than the normal range of motion) every time.

Could you please shoot a video about this and then upload it to Dropbox or Google Driver and share me the link?


Could you please remove the load and let the uArm work with universal holder or Gripper only? Is it the same phenomenon with the load on?

uArm Serial No.: C8FD19405647
Firmware Version: 3.1.9
Operation System: MacOS Sierra 10.12.5
uArm Controlling Method: Serial port direct GCode commands

Hi, I’m having the same problem with spontaneus wrist movement. It has happened while moving the uArm using G commands through the serial port, but also even when using draw feature in uArmStudio software. This last thing, obviously, ruins completely the drawing being made. It does not happen always, but quite often to be very annoying.

I’m also having the same issue while issuing commands with gcode. It mostly happens during the arm getting lower and it happens without load as well. Need an urgent help. Thanks.