xArm7 Joint position error

Hi, I have xArm7 robot and I have been using it for months.

Yesterday, I started the robot with xArm studio and Joints Angle limit exceed error occurred likely in joint 4.
when I tried to clear the error and move the robot to initial pose s34 (motor overload) error happened likely in joint 4.
Then I supported the robot by hand while adjusting the joint position in xArm Studio by using sliders until the motor overload error is solved.
NOW, the robot works fine but the position data coming from the encoder reading and the real robot’s joint 4 position is different and I couldn’t use the robot anymore.
How to fix this issue? and here is a link for a log file.

Thanks in Advance.

Hi Amanuel,

To reset the zero position of joint4, please enable ‘manual mode’ and move the actual arm to its original zero position, enter ‘Settings-Advanced Tools-Debugging Tools-Joint Debug’, and send ‘D13 I4’ to reset the current position of joint4 as 0°, press down the E-stop button and release to take effect.

‘D13 I*’ is used to reset the zero position, * stands for the joint ID.
Please consult the support team support@ufactory.cc before using this command, as it will reset the zero position and may affect accuracy.

Best regards,

Thanks a lot @Minna for a quick support.
I successfully reset to zero pose, tested and it works fine now.

thanks again,