3D Printing - Abruptly stops before finished

uArm Serial No.: UARM05051706EB

Firmware Version: 315

Operation System: Mac

uArm Controlling Method: uClient/Cura/uArm Swift Pro print monitor

uArm successfully made a few 3D prints. Now it stops before the print is finished. Sometimes it locks up. Sometimes it just drops the extruder into the print. In all cases, Cura print monitor extension cannot talk to the arm, unless the arm is restarted (power cycle).

I was running Beta uClient/Cura. Downloaded released software, no help.
I attempted Firmware upgrade to Version 316. uClient says success, but still 315.
The problem persists.

I suspect overheating electronics. I see no means of ventilation.

Question: Is the board a standard Arduino Mega? Can I replace it?


uArm User Facebook Group
Contact Us:
English Channel


It’s a problem of the latest Studio-1.1.13p1, we’re fixing it now.
Please flash firmware(3.1.16-dev) manually according to this FAQ.
And try again.

Thanks. Sorry for the trouble.

Btw, the board is based on Arduino Mega 2560 but modified by the uArm Team.


Please check if the Bluetooth button is up (the button beside the power). If it’s down and connected by the other BT device, it will stop. And please check the connection of hot end to make sure it’s well connected. Drops might be caused by the temp error.
The mother board in the arm is designed based on mega, and integrated 4 stepper drivers.

Thanks to Tony and Xitong. I believe it was the Bluetooth button. It all seems to work now.

Also, I successfully upgraded firmware to 3.1.16. Thank you.

1 Like

It might not have been the Bluetooth button. It happened again this evening. Perhaps overheating?

Did you see any error message on your Printer Monitor window?

There is no error message in the Printer Monitor window.

That said, I just upgraded to 1.0.4. The print head does not drag through the previously printed plastic like it did with 1.0.3. My test print isn’t finished yet, but is is progressing beyond where the uArm stopped when I was running 1.0.3.

1 Like

Nice to hear that, and keep us informed about your test. Thanks

I spoke too soon. Before my print finished, the arm went limp and dropped the hot nozzle into the piece. I have to leave for work now, but I’ll check the screen and log file when I get back.

I also was having this problem. I updated studio and cura to the newest builds. Ran a project, worked great for 4 hours, then with about 30 minutes left in the program did the exact same thing described. I am not using bluetooth. The uarm studio indicated that the arm was not connected when I went to look at the program. Cura showed no errors.

All of the logs just show regular commands with no change. The log just stops until several hours later when I discovered the machine had stopped and closed everything down to clean up.

[DEBUG] 2017-08-03 02:11:44 [UArmWebSocketClient.py:on_message:200]: Receive: {“type”: “broadcast”, “data”: {“progress”: “83.09”}, “cmd”: “uarm_printing_progress”}
[DEBUG] 2017-08-03 08:30:33 [UArmWebSocketClient.py:send:93]: Send: {‘id’: 4, ‘cmd’: ‘stop_3d_printing’}

2017-08-03T09:11:44.563Z - info: [DEBUG] 2017-08-03 02:11:44 [gl.py:broadcast_printing_progress:431]: Printing Progress: 83.09
2017-08-03T15:30:33.653Z - info: [DEBUG] 2017-08-03 08:30:33 [message_process.py:process_message:32]: ===========stop_3d_printing=================

1 Like

The uArm electronics are overheating. My answer was in uArmCore.log

2017-08-05T04:29:59.418Z - info: [DEBUG] 2017-08-05 00:29:59 [message_process.py:process_message:32]: ===========start_3d_printing=================
2017-08-05T04:30:14.041Z - info: [DEBUG] 2017-08-05 00:30:14 [command.py:start_3d_printing:622]: Receive Gcode data: len=14647499, lines=506822
2017-08-05T04:30:30.757Z - info: [DEBUG] 2017-08-05 00:30:30 [gl.py:broadcast_printing_progress:431]: Printing Progress: 0.00
2017-08-05T04:33:07.313Z - info: [DEBUG] 2017-08-05 00:33:07 [gl.py:broadcast_printing_progress:431]: Printing Progress: 0.01
2017-08-05T04:33:56.390Z - info: [ERROR] 2017-08-05 00:33:56 [uarm_printcore.py:_listen:149]: Error:Thermal Runaway, system stopped! Heater_ID: 0
2017-08-05T04:33:56.393Z - info: [ERROR] 2017-08-05 00:33:56 [uarm_printcore.py:_listen:149]: Error:Printer halted. kill() called!

I would let our engineer to double check the log file to find the exact cause of this issue. Would you please send us your log files? Thanks

I’ll send log files. Apparently, I’ve had the Thermal Runaway error five times. The uArm has quit on me more often than that.

grep -i Thermal *
uArmCore.log:2017-07-30T03:30:36.069Z - info: [ERROR] 2017-07-29 23:30:36 [uarm_printcore.py:_listen:149]: Error:Thermal Runaway, system stopped! Heater_ID: 0
uArmCore.log:2017-07-31T00:10:08.396Z - info: [ERROR] 2017-07-30 20:10:08 [uarm_printcore.py:_listen:149]: Error:Thermal Runaway, system stopped! Heater_ID: 0
uArmCore.log:2017-08-05T04:08:03.620Z - info: [ERROR] 2017-08-05 00:08:03 [uarm_printcore.py:_listen:149]: Error:Thermal Runaway, system stopped! Heater_ID: 0
uArmCore.log:2017-08-05T04:26:33.764Z - info: [ERROR] 2017-08-05 00:26:33 [uarm_printcore.py:_listen:149]: Error:Thermal Runaway, system stopped! Heater_ID: 0
uArmCore.log:2017-08-05T04:33:56.390Z - info: [ERROR] 2017-08-05 00:33:56 [uarm_printcore.py:_listen:149]: Error:Thermal Runaway, system stopped! Heater_ID: 0

I had been running with the default 4mm/sec print speed. I increased it to 8mm/sec this evening, and now I seem to be getting better behavior. The piece I want to print has a 2" x 10" base. The printer would print a 2" line and a 10" line (@ 4mm/sec) and stop every time, even when cold. Changing to 8mm/sec got me past that blocker… until I ran out of filiment. I have more on order.

@hoodel @JekBear

Please let me know when you uploaded log files through the [Feedback Form]

I uploaded (or tried to upload) 3 log files: app.log; curaforuarm.log and uArmCore.log. Not knowing if it is a software problem, or hardware issue, I clicked others. I couldn’t tell if it took all three logs.

Thanks. it may be a overheating problem. our engineers are dealing with it.

@hoodel @JekBear
What’s the indoor temperature when the 3D printing problem happened?

The temperature in the room is variable: 70 - 80F ( 21 - 27C). It was on the warmer side when initially reporting. It is cooler now, and the problem persists.

[20170811 addendum - I just recalibrated, which improved Z-position accuracy.
Print still failed early in the first layer. Ambient air is about 78F (25C). I just posted clean log files.]

Maybe the cause is not temperature [in all cases]. The experiment I’m running suggests a different root cause.

The machine I was using had 4GB of RAM. I have hooked up a different machine with the same OS, but 16GB or RAM. The ambient temperature is 81F (~27C), and after 2 hours, the print has not halted.

I suspect the culprit might have been Garbage Collection kicking in on the small machine, interrupting communications. I’ll provide an addendum when the print completes, successfully or not.

[ 2017-08-13T12:15:-- Addendum: 20 hours into an 81 hour (est) job, and it is still printing. It is looking like there was something about the smaller (memory) computer that the uArm didn’t like. ]

[ 2017-08-15T12:08:-- Addendum: My print ran to completion, and I have started another one without mishap.
Pass: OS X 10.10.5, 2.5 GHz Intel Core i5, 16 GB
Fail: OS X 10.12.6, 2.66 GHz Intel Core 2 Duo, 4 GB ]