Cannot upgrade Studio and Firmware


I have the following:

  1. xArm 7 that runs firmware v1.2.5
  2. latest xArm python-SDK
  3. on my laptop I have the UFactory Studio v1.0.1.
    I am trying to use the SDK to develop a project, but when I run any of the scripts (like “”) the robot arm moves just a tiny bit and stops and I get the error:

SDK_VERSION: 1.13.16
Please input the xArm ip address:[SDK][ERROR][2024-01-10 16:13:36][] - - report data error, close, length=233, size=245
The thread 0x5 has exited with code 0 (0x0).
ROBOT_IP:, VERSION: v1.2.5, PROTOCOL: V1, DETAIL: h2,v1.2.5, TYPE1300: [0, 0]
[motion_enable], xArm is not ready to move
[set_state], xArm is ready to move
The thread 0x7 has exited with code 0 (0x0).
[SDK][ERROR][2024-01-10 16:13:38][] - - report data error, close, length=233, size=245
The thread 0x8 has exited with code 0 (0x0).
[SDK][ERROR][2024-01-10 16:13:41][] - - report data error, close, length=233, size=245

So, my questions are:

  1. Is the latest python-SDK compatible with the firmware that I got on the arm (v1.2.5)?
  2. I thought maybe I need to upgrade both the arm firmware and the UFactory Studio software?
    BUT the problem with this is that the upgrade options are dim, it doesn’t allow me to upgrade in any way. I have tried everything - and the robotic arm is connected to the internet and still the same issue.

I need guidance with point 1 & 2 above, please!

Thank you!

Hi Deeman,

Firmware V1.2.5 is a really old version, Please try to update the firmware and UFactoryStudio to the latest version, for more details please refer to the link below, you can try to do the offline update.

If there are still problems, please provide the SN of xArm7 to
Is there any error prompted in our UFactoryStudio?

Best regards,

1 Like