Many problems with 2.0

We updated Studio and Firmware yesterday and have encountered many problems!

We would like to downgrade back the previous version because we need to complete
orders for our customers. Please send me information on how to reverse the
update of App Studio and the robot firmware (if necessary).


Andre Sant’Anna
Director, R&D
Applied Anodize, Inc.

Some problems encountered (1 and 4 are critical):

  1. Our production program now gets C23 errors (speed exceeded). We have tried
    to do simple adjustments to speed and accel but can’t get it to work. This program
    used to work fine before the update.
  2. Updating lost all of our TCP presets
  3. Changes to UI (white background) makes our operator instructions unreadable
    (we used colors heavily to increase visibility against the black background)
  4. The Blockly editor zoom function is broken somehow with the scroll wheel of the mouse.
    The zoomed area jumps around unpredictably. We can’t use the editor like this.
    The editor is also very laggy, quite painful to use.
  5. The “create new file” button sometimes doesn’t appear. Making it impossible to create
    new programs. We have to restart Studio to make it come back.
  6. The “quick copy” function cannot be saved. Pressing “save” does nothing.
  7. The “enable robot” button does not appear to do anything. However the robot is enabled.
  8. Changing to “reduced mode” does not update the information in the little window on the screen.

In my opinion, this update has serious quality issues! We tried the update to see if some intermittent
problems we have been experiencing got fixed. But now we are stuck!

Additional information.

We identified the speed limit problem to different behavior of our xArm7 robot with the new update. For some reason, rounded corner movements when x, y, pitch and yaw are all changing at once in a certain way used to work but now fails.

We experimented with different values for pitch and yaw and managed to get it to work. We did not have to modify speed or acceleration. Perhaps there were changes to the IK algorithm?

The enable problem has not returned after we solved the previous problem and restarted the controller. Maybe something is left not quite right after errors?

Hi Andre,
For the C24 issue(Speed Exceeds Limit), is there any chance we can get a script from you to reproduce that issue with our xArm7?
And if you could reproduce the C24 issue and download the log and send to us,and provide the date/time when you reproduce it, it will be nice.
Thanks in advance.
My Email is

If you need downgrade the firmware/software to the last stable version, that should be firmware V1.12.10 and software v1.12.4, here is the link to download the firmware/software: V1.12.10 - Google ドライブ

Make sure to use the xarm-tool-gui to process the downgrade,here is the link to download xarm-tool-gui, choose the gui version based on your PC’s operation system.

For the other issues you feedback, we will look into it and try to fix them with the next versions.
Thanks very much for your feedback.