Questions and problems re: New uArm Metal at MakerFaire

Hi, I purchased the new version uArm Metal last week at Makerfaire in San Mateo. Unfortunately, there dies not seem to be any documentation (for the new version), nor does any of the downloadable code seem to work. It is also missing the vacuum tubing.

My first question- What do the buttons and lights do on this unit’s controller board? It isn’t the older style board- this one has an Arm MCU on it for example, and the parts placement is different. My “guess” is that one of the buttons is reset.

#2: I carefully downloaded and installed the drivers, mouse app and uClient - and they do not seem to work. The Silicon Labs driver installs correctly,(as Com 8 in my case), and the both the mouse app and uClient “see” Com 8, But… they can’t make anything move, only one of the lights (a blue LED) on the uArm’s PCB blinks. Yes, I do have it plugged in,

#3: Is the new controller board similar to one of the Arduino boards? It’s obviously not an Uno clone- it has an Arm MCU on it. But it doesn’t seem to be an Arduino Due either. Is is something I can load sketches to? If so, how? Also, how do I upgrade the firmare if/when you release new versions of firmware for the new unit?

#4: What is the best way for me to get the missing air tubing for the vacuum? The vacuum unit was in the box, but no tubing. Maybe there are other things missing, I don;t know. The box had a red sticker on the outside with a " # 4" written on it, if that’s helpful.


I am in the same boat. Have you found information on which set of pins and in which orientation the fourth (suction cup rotation) servo plugs in?

FWIW I just went to the hardware store and bought 3 feet of .17 inch I.D. vinyl tubing as mine was also missing.

I’ll try to help with your questions as best I can.

Make sure you power the uArm using the barrel adapter first. Do not attempt to power it using only USB.

If you are using mouse app/uClient, you are using the older firmware and calibration methods, so you probably should have followed the steps here:

One: The reset button is on the front side to the robot’s left side (opposite of the buzzer). The other two (D7 & D4) are definable in software. These, and much of the other pin info, can be found in this image from

Two: As I wrote to @clinzy, there may be an interaction issue with the driver on Mavericks. I don’t recall exactly how I fixed mine but googling seemed to give me the answer. Try these:

Look through that earlier getting started link for calibration info and how to get uClient running.

Three: I have always just selected “Uno” and everything has worked (once the drivers are set up). You can certainly upload your own programs and use the firmware package that is continually updated.

To be clear: The old firmware that works with Mouse app/uclient is here:

(I think this is pre-loaded).

The newer general-purpose firmware, on top of which one might build a custom robot solution is here:

Docs for most of the current firmware libraries can be found here:

Note that you MUST calibrate your uArm for the libraries that you are using.

Four: Hmm, my vacuum came attached so I can help if you need a picture of how something attaches, if that’s needed…

I hope some of this helps…

Since I also bought my unit from the booth at Maker Faire, I suspect that the board shown above is, as is the case for mine, not at all the board that is in the hardware.

Thank you for your quick response, @DCorboy!

But the new uArm Metal PCBs, such as the ones that @clinzy and I have (and anyone else who bought one at last week’s Makerfaire) are completely different from the older models. These are not Uno clones; in fact the on-board MCU was upgraded to a 32-bit ST Microelectronics ARM processor, not an 8-bit Atmel ATmega MCU as on the Uno. So unfortunately the very nice pinout you have does not match the new series of uArm PCBs. Thanks for sending it anyway!

Confusingly, there seem to be at least two download locations on the uFactory site. I tried downloading and installing from each, after uninstalling them between attempts. No go. All I get are blinking blue LEDs when the mouse is moved. At least that tells me that the virtual com port is working.

Also, I am using Windows 7. I assume Mavericks is an Apple OS.

Regarding the vacuum, the airline tube and all the vacuum pick-up parts for the end-effector side were missing from the box. Only by studying the picture on uFactory’s uArm Metal page can I see what else is missing. It looks like there is a limit switch, metal collar, and some black object with fits inside the end-effector. Not sure. In any case, uFactory will have to ship them as they are missing. I can probably find airline tubing locally but not the other machined/molded parts.


Yes, exactly. All of us that bought the new uArm version are in the same boat. They have different PCBs with a different layout and a new (upgraded) microcontroller.

I’ll look at the vacuum servo in a few hours. I don’t know if it’s connected right though, since I can’t control it.

Wow, I wasn’t aware of all the changes! It seems my hardware info and documentation references may no longer be good!

Nice to have you here, @ces & @clinzy. New folks will definitely benefit from your knowledge around the new boards.


In my attempt to find information on Arduino for STMicro ARM I found that apparently the first Arduino with the STMicro ARM chip also launched at Maker Faire this past weekend.

Hi @clinzy - it thought you were referring to the vacuum pump. I looked at a picture of the new uArm Metal on the uFactory web page, and realized there’s supposed to be a servo on the end-effector too. Guess I’m missing that too! Not happy so much of the system was not in the box when they handed it to me at MF. I contacted their support and have a “ticket”, but no response. We’ll see…

Ah I had emailed them twice this week but I just now found the support ticket system. I will let you know if I get a response from either channel.

I finally got a response from and after some emailing back and forth was sent a PDF manual for this new arm. If you have not already, I suggest emailing to that address concerning your missing parts.

You can send an Email to us at, and we will do our best to fix the problems.