Swift pro 3D print feeder not working properly

the uarm work almost perfectly on laser engraving now thanks to Cleo help :slight_smile:

So tried the 3D printer part, and only find that it seems the feeder module does not work properly.

When 3D printing, the feeder keep pushing then PULLING the PLA continuously in a loop, instead of JUST pushing the PLA material to the hot extruder. Therefore it can’t print anything because the PLA cannot be pushed to the extruder.

I have followed the official PDF instruction and 100% sure the feeder module is installed correctly (the panel that stick to the uARM is aligh to the LEFT, not right as instructed?) Not sure it’s correct at first because the small logic board for feeder is kinda blocking the power cable to uArm.

Hi there, the feeder module is supposed to be connected in the middle, not right or left. The stepper lose steps means the connection is not correct as well. Please double check the connection carefully, thanks

The stepper lose steps means the connection is not correct as well. Please double check the connection carefully, thanks

I did exactly like this:

the port on the uArm base got extra 2 holes on the RIGHT SIDE OF THE PORT, (NOT the right side of the uArm base) that’s not used by this circuit board, if I read your PDF correctly?

I had a trouble getting the 3d print head to work.
I found that pushing the pla through the pipe didn’t actually make the plastic go into the extruder, I had to undo the bolt at the top of the extruder when the feed pipe goes in and push extra plastic out of the feed pipe then guide the plastic into the extruder. Before doing the bolt up again,

I hope that makes sense. I’ll take some photos later if it doesn’t

I have done this, but still having the same trouble as Maximilian where the feeder will push some pla through then jump back, so nothing actually appears to be getting out of the end of the extruder.

@Shiv @Maximilian Does the extruder motor works properly? If the extension is connected correctly, there won’t any sound of clicking from the extruder and you can find out that the motor tries to push the PLA into the PEFT tube. The base extension is not a good design, it is neither aligh to left nor to right. It should be in the middle. If there is still any problem, please give me a video and I will try my best to help you. Thanks

hi, i think im having the same problem as you did. if you could, pictures of that would be great

Ok now that’s a MUCH better picture. You may use this in the PDF instead of the current one for better explanation :slight_smile:

I am currently doing the TOO LEFT version as that’s what I get from your official PDF.

Will try this weekend.

Already done, thanks for your feedback. :slight_smile:

Sadly my connector is in the correct place. There is no sound of clicking, it will attempt to push, then seems to be jumping back when it cant anymore? I will have a fiddle tonight.

I found my issue, My apologies! somehow the pla had snapped inside the tube and was causing all kinds of issues, I was super gentle putting it in the second time and everything seems to be running!


Hi, I thought I had the same problem as Shiv, my connector appears to be in the right place but the feeder jumps back every few seconds when it runs out of space to push into. I checked and it seems that the filament is reaching all the way to the extruder but it’s not getting through to the other side and printing. The extruder is heating all the way to 200 degrees, the feeder is pushing filament, and it is reaching the extruder but the filament stops at the extruder and won’t print. I tried handfeeding the filament to the extruder but when I pulled the filament back out it didn’t even look melted.

The filament might be stopped in somewhere in the tube, and it’s not reaching the hot end.
Could you please show us a video? That helps a lot

The videos were too big to upload here so I uploaded them to imgur - link: http://imgur.com/gallery/JFDXS

The filament is not getting stuck in the tube, as I showed in one of the videos, I even tried hand feeding the filament into the extruder without the tube and it still wouldn’t melt/go through.

It’s definitely reaching 200 degrees; I touched a piece of filament to the outside of it to check and it melted.

The filament is getting all the way to the extruder and getting stuck there somehow. Then, as the feeder keeps pushing filament in, the pressure builds up and the filament jumps back through the feeder.

this is exactly my situation.

Try the picture below.

i have the same problem and i made sure both ends were locked but it still didn’t work

The tubes are locked in for me too, still no luck.

@adam @nihar.patel628 please show us more details by a video (my email address: tony@ufactory.cc)? That would help us to find problem quickly! Thanks :slight_smile:

I’m having a similar problem. At step 4 of the manual, when I must keep feeding the PLA until it’s 60 mm out of the PTFE tube and go to step 5, where I must install the tube to the extruder, the PLA only enters for 40 mm and leaves 20 mm out.
I´ve tried to print nevertheless (taking back 20 mm of PLA) and see how the temperature reaches 200ºC and everything seems to be ok, but then I notice that no material comes out of the extruder and see that the feeding motor tries to push the PLA, but isn’t able to fulfill it’s task.
So the problem is that I’m not able to deed the extruder with 60 mm of material. I gets somewhere inside stuck. There’s something inside the extruder’s tube that doesn’t allow the PLA to reach the extruder’s head.
This is my first printing, so there shouldn’t be anything inside the extruder.