Swift Pro not working at all

Anybody out there???
My Swift Pro is not working at all.
Why doesn’t anybody care???
Wanna buy a uFactory Swift Pro??? Cheap.

Hi @NorthernPike

Sorry for the trouble.
Please specify the problem that you’re facing so we can deal with it, thanks.

Finally got your attention eh Cleo? You want me to specify the problem. Ok. I turn it on, plug in the USB. That’s as far as I can get. Try the pushbuttons to manually make some movements but no way. Not working as specified. I tried Arduino IDE which compiled and uploaded and then nothing happens. I start Studio and when it connects it says the arm is a Swift, not a Swift Pro. And again, none of the features of the Studio app work. I don’t get it. What did I buy???

Hi @NorthernPike

It seems that your uArm has the wrong firmware.
Did you upload any Arduino library before using Studio?

My suggestions is that you may flash firmware manually:
The steps are explained in this FAQ.
Please let me know if it works. I’m here to help. Sorry for the trouble.

Hello Cleo,
Ok, here’s my status.

  1. FirmwareFlasher downloaded. .hex file downloaded.
  2. Flasher had trouble. Timeout error. Saw Swift Pro on COM5, clicked OK, but no go.
    2a. Rebooted PC. Power cycled Swift Pro.
    2b. Executed FirmwareFlasher. Dragged .hex file into Flasher. Saw Swift Pro on COM4, clicked OK.
    2c. 25%, 39%, 54%, 79%, and walla, Swift Pro flash successful.
    2d. Threw my arms into the air yelling HOORAY, IT WORKED, SHE’S BACK!!!
  3. Execute Studio. Connects to Swift Pro. Reports Firmware 3.1.18 which is correct Yes/No? HOWEVER…
    3a. Clicking on menu item “About uArmStudio” I get an error dialog.
    3b. Download Studio again for latest. Windows reports unknown provider, I click install anyway.
    3c. NSIS install error. I can’t install the Studio. Why? Is it because I have an earlier version already?
    3d. Do I need to “Un-Install” Studio first, then install a new download?

Hi Pike,

Several users also reported the NSIS error and we got it fixed during the weekend.
I’ll test the new Studio today and keep you updated. Thanks.


Sounds like I am having same problem. Its just not working. Did you get it up and running?

Hi @Michael_Vittorio

We found that the js error window pops up under different situations.
We fixed part of it before and now a thorough testing is being done to ensure the next version won’t have this problem.
The next version(v1.1.14) will be out next week.