Suction Cup control

Hi, I just receive the suction cup control. But the Xarm studio seems didn’t has suction cup control fuction in Blockly control, right? May I know when will it be ready? In the meantime, how could I use the suction cup control? Please advise!

Hi, it did support the suction cup, please check the latest user manual:

Hi Daniel, But my Xarm studio seems has a lot of missing features. In the “Setting” - “Tool Setting”, it only has the item called “Is Gripper Installed”, nothing about “Suction Cup”. Refer to the manual, my Xarm Studio are very different to the manual. Mine are just missing a lot of feature. My XArm studio is version 0.5.0, I am using Mac Pro 10.14.5. Please advise!

Hi, 0.5.0 is the version of the xArm Studio client, what you need to upgrade is the xarm studio server and the firmware.
Please check the page 85 of this doc( to upgrade the xarm studio and firmware of the xarm.

OK, I follow the manual setup, both my computer and control box also connect to the router which is connect to the internet. In the Xarm studio, both the software and firmware update button are dimmed, cannot be press.

It seems that the Firewall stop the controller from accessing the internet.
No worry, here is a tool to install the latest xarm studio and firmware, the user manual is in the file folder, please check it here:

The offline update works. I have all update to version 1.4. Thanks a lot :slight_smile:

you are welcome, looking forward for more feedback of the product. Thanks.

One more question. Is the Xarm studio available to use when the Xarm is not connected? You know that it is very time consuming to program the robot arm, i just hope that i could use the stimulation mode to program the Xarm when i have time outside the studio without Xarm. Possible?

No, because so far the simulation function for the xarm is not good, we can only simulate the joint, we can not set cartesian coordinates for the xarm on simulation environment, so we don’t provide the simulation for program.

Hi Daniel, Suddenly, I got the "Set suction cup code=41’ error. I use Blocky code, when the code go to “Suction cup On”, it appears this error and stop running. I reboot both the arm studio and the xarm twice. It still not work. Pls advise!

Is the suction cup button on the Live Control page still working?

yes, it works on Live control page.

If running the code it appears this error.

Did you use the firmware 1.4.1? Could you send me the screnshot of the Blockly code?


It used to work at the first few times today. But suddenly get error. This is just use a simple code to test the the suction cup again. It still doesn’t work.
I am using 1.40 firmware.

Please set the wait=false for the “set ari pump” command, and add “wait” command if you need wait for the suction cup to pick the object. Let me know the result.


If set wait=false on “air pump” command, it works.
But I find the problem, if I add the “set TCP acceleration speed” or “set joint acceleration speed” on the code, it get error again.

could you show me you new code?