Westmi "Bugs with Pro so far"

uArm Serial No.: (the No. at the bottom of each uArm reading “UARM-XXXXXXXXXX”)
Firmware Version:
Operation System: Win 7

uArm Controlling Method: uArm Studio Blockly

Ok here is a list of the problems so far in Blocky Program:

  1. The vacuum hose provide kinks. It is to soft and I had to disconnect and install new hose which i zip tied to the arm. Please tell me how to remove the old hose and replace with new. It appears to be stuck in the upper arm and I can’t pull through. Need to know how to dismantle and replace hose without damaging anything
  2. Pick and Place Control wrist does not rotate. Checked connections numberous times but still nothing. I thought one time I heard the motor run but wasn’t sure. Need work through
  3. Full Speed setting does not work. Once activated it goes to 1X speed. I can only get about 9.5 picks in one minute.
  4. Mounting holes on Grove Mounting Plate do not line up with OPENMV camera chip backing plate. The Grove mounting bracket holes are to close. Please send me a new one.
  5. Need to have preprogram limits for all arm rotations so you can exceed values and strip the servo gears. I have played with some of the settings in the blocky Program on movement and notice some times, not all the time the motion is limited. When it is not you get the servo gear strip, the mahine program is trying to go there, however it mechanically can’t. Thus the stripping of gears.

Official Store
uArm User Facebook Group

English Channel

Hi @westmi

  1. Sorry for the trouble but please don’t remove the old hose yourself coz you’ll have to dissemble the arm completely to do that, which will cause damage to the arm.

  2. Here is the connection instruction:
    If the connection is right and the wrist still can’t rotate, please send a video to us. So we can check whether there’s a hardware problem. Thanks.

  3. & 5) We’ll fix these two problems in the next version. Thanks for your feedback!

  4. Please send us a picture of the problematic module, thanks.

Ok will send you a video tonight. Also please disregard item #4. I was using wrong mounting holes. Lastly can you please tell me the vendor for the wrist controller and vacuum cups. I want to be able to change out the vacuum cups for various sizes. Right now I need some smaller cups.

Cleo I hope you can see this? If not I need and email to share the video to. Cleo also name of wrist vendor or a link to different suction cups attachments. I need smaller cups.

After sleeping on this last night and looking at Java script I notice the wrist has no axis denoted. Do I need to denote an axis for the wrist to rotate or is this automatically happening through the Arduino. I would think this 4th axis would need to be defined?

Getting no Open MV cam found error message. If you see the video there is power and it is blinking. I have the wires connected tx2 to P5 and Rx2 to PE. Removed plugs and reconnected several times. Wiring is correct. Open MV board DV7725-M7.

Hi @westmi

I can’t access the video link. Could you send it again? Thanks.

The GCode command to control the 4th axis is “G2202 N3 V80”
N - ID of the servo (N3 is the 4th servo)
V - the degree of wrist-turn (V80 is to turn to 80 degrees)

You can get small suction cups like this:

Ok here is a shared link. Ok I am a novice a this. G code? I am working in Blockly with the wrist command, I need to edit that command or build a command.

Thanks for the info.

Did the wrist reset to home position when you use the “Reset” command or press the stop button in Blockly? If not, it may be a hardware problem.

Btw, what error messages do you get while using OpenMV?

Let’s skip the wrist issue and focus on the OpenMV issue. I haven’t messed with the machine for awhile and I am trying to tackle the issue this weekend. I have tried to download the information to the MV7 camera. Below is what I posted over at the Open MV forum. Since I have done this, now the robot will only stay connected via USB directly to computer, when I turn on the power to the robot I lose USB connection. Grrrrrrrrrrrrrr! Need quick fix for this. I am dead in the water now, can’t do anything. For a million dollars in sales you need a help line, chat line or something. Working through a forum is very slowwwwwwwwwwwwww. Sorry for venting I am just really frustrated now.

I currently own a UARM Swift Pro pick and place unit and I can’t get the M7 camera to be recognized by the Arduino Mega 2560 board. I have tried everything to get the camera to be recognized by the board but to no avail (Hit connect button, don’t erase internal file reboot, erase internal file reboot, jumper out boot to RS, Stand on my head, etc) The camera has power and the blue light is blinking, for whatever reason it just won’t recognize the camera. The manual calls for the connectors to be P5 to RX2 on Arduino, P4 to TX2 on arduino, ground to ground, VIN to 5V. I have Open MV version IDE is 1.7.1, and have no idea what version firmware I have for Open MV CAm (STM32F765). Can you help. I am a novice at this stuff, so please be patient.

Hi westmi, this is Tony from uArm. First I want to confirm if you follow the quick start guide. If so, would you please tell me which step are you getting trouble with? If blue light is blinking, it means you have successfully upload the demo code(tracking.py) to your openMV camera.
You mentioned the recognition, do you mean the uArm cannot be recognized after connecting the camera?
By the way could you please give us some pictures or videos to find the trouble?
Thanks and feel free to ask any question about the robot

Tony will get something posted within the hour. Right now I can’t get the unit to home.
Plug in power cable
Press down power button
plug in USB.

The unit does not recognize the USB connected. It only will recognize the USB cable if the power is off.

Issue with camera.

Hook up to work computer and still the same problem. I think I need to map the Arduino board to the Uarm. I do have Arduino software on my personal computer and I think now the U-arm’s arduino board is looking at that software instead of the robot’s as the parent. How do i confirm this is not happening, can how do I correct?

Hi westmi, checked the video, the biggest problem is you didn’t connect the openmv to PC with USB cable. OpenMV can only be recognized when being connected directly to PC. The connection with robot arm is a demo which makes the openmv and robot work together without the computer.
So the correct step is 1,connect the openmv to PC directly and download the tracking.py in openmv IDE successfully; 2,disconnect the openmv with PC and connect it with robot like your video shows (now the openmv cannot be detected by PC); 3,plug in the USB of robot and power supply, then turn on the switch; 4,send the command as the quick start guide said; 5,the rbot moves up and tracks the objects in camera.

I got the camera to work connected directly to the PC. Thank You. However, I am still having problems getting the robot to track. I am having problems with Step 9 and 10 in your quick start manual. My Arduino IDE is not recognizing the Mega 2560 board through the serial monitor. My serial plotter in step 9 is not regonizing the Mega board 2560. Made sure my ports in my Arduino IDE are on the right channel com 6. I get this error message in the Arduino IDE." processing.app.serial exception: Error opening Serial port com 6.

I think I need to upload the sketch_jun30a in step 10 first, and then I can see it functioning in the serail monitor in step 9. Anway I need this file, where can I find it to download to my Areduino IDE files? I feel I am very close now to getting this. Thank You

Void this sentence please

Tony I need to ship back this arm. I can’t get the servo’s to home anymore like you saw in the video. At times I can get the camera to through the USB to the computer and see the serial monitor running. I never can get the serial monitor and the servos to run in conjunction. For whatever reason the servos will not home at all in any program (i.e. self teach, blockly, etc.). Please advise where do I ship my machine back to.

Hi westmi,
Could you please show me more details about the not getting servos home? Do you mean the arm cannot be recognize in your PC? Since there are some backer who are getting trouble with the AC power adapter which keeps resetting the arm, so I am wondering if it might be the same problem as well. If there is anything wrong with the arm, we would send you the replacement as soon as possible. Thanks for your understanding!

This video I can get the the USB to connect but the Servo’s will not home or power up.

This video you will see I can’t get the PC to recognize the Areduino Mega 2560 board or power up servos. It’s like sometimes it works and sometimes it doesn’t.

Bottom line ever since I have been trying to get this camera to work the robot arm stop working.

Hi westmi, from the video, you connect the USB cable first then press the power button, at last you plug in the power supply. And you are using windows 7 OS. Since we have got some feedback about the failure recognition of studio which might cause the trouble, would you please following the steps one by one:
(we strongly recommend win10 pc if you have, much more stable)
1,power off the uarm and restart the pc;
2,plug in the USB cable and power supply;
3,press the power button;
4,check if each function of studio works fine.
If the issue is still there we would do the replacement of uarm or there might be some issue with the connection and camera. Thanks for your cooperation!