Xarm6 w/ Robotiq 2F-85 Gripper / Wont operate from code (only manual triggers). Please Help!

Hello, I have an Xarm6 with a Robotiq Gripper 2F-85. I followed the guide listed here: Guide to use the Robotiq Gripper on UFACTORY xArm | UFACTORY Help Center

I am running the current version of Ufactory Studio, 2.2.2 and latest firmware 2.2.2

The gripper funtions normally in Ufactory “Live Control”. It also works in Blockly Code IF you Click on the individual block in the code like “set” in the initialize block or “set” in the set robotiq gripper variable (for testing). However, when you integrate those blocks into an actual program and execute it , it just hangs on the “Initialize robotiq gripper” and does not execute the motion/command. Once again, If you click “set” manually in the same box it works fine, but when it’s integrated in code and you execute the entire program it hangs on initialize or hangs on the other “set robotic gripper position/speed/4/wait” block. The LED turns blue on the Robotiq gripper as if it is receiving the command from ufactory studio, but nothing happens, and the program stops on that block without proceeding to the next. When you manually activate the block for testing, the LED turns blue and the gripper action happens. I have attached an screenshot to this post for reference.

Another thought: Is it normal that the LED is solid red on the gripper when it is not receiving a command? Per the manual this means: Minor fault (LED continuous red) “l 0x09 No communication during at least 1 second” It turns blue when it gets a command from UF Studio (and executes it when sent manually). Should it stay solid blue all the time? Should UF Studio be sending some kind of “keep alive” signal?

The 3D Animation of the arm in “Live control” shows the arm moving, but there is no animation on the gripper open/close action. Is this normal?

I’m thinking this may be a bug in UF Studio since the functions work fine when manually triggered. I also tried running the same code when converted to Python from Blockly and the same thing happened.

Please help me, I purchased this very expensive gripper trusting that it would work with my Xarm6 due to the very nicely written integration article and now here I am with a nonfunctioning gripper.

Thank you in advance!

EDIT (False alarm, Still not working, see 3rd post)

Okay, I was up until 3 AM last night aggravated, and and managed to figure it out. It’s working great now. The blockly code posted in that article does not work in the current version of UFS. The secret is to “set and move” In the initialization block for the robotiq gripper. here’s a screenshot:


After the gripper is initialized, remaining “set robotiq gripper” blocks seem to work fine without needing to add “and move”.

Hopefully this helps the next guy!!!

EDIT!!! Nevermind… It does not work anymore. Same behavior as in the original post. What the heck???

It should not so complicate to use the Robotiq Gripper, it’s designed as easy to use as UFACTORY gripper. We will test and get back to you this week.

Thank you! I am stuck.

We are able to reproduce the issue, we will fix it and let you know. The version fix the bug will be V2.3.0 and should be released in around 2 weeks.

PHEW! Thank god its not just me :slight_smile: If this could be done as soon as possible it would be a great help, my XARM cant be used for its tasks without the gripper code working.

I will be watching for the release. I’m sure many others out there with the Robotiq Gripper will see this and save them. Don’t forget to update your document here when its done: http://help.ufactory.cc/en/articles/3997200-guide-to-use-the-robotiq-gripper-on-ufactory-xarm

Thanks again Daniel!

Checking in on this, how’s it going?

Beta testing, final version should be ready in this week. Do you want to try the beta version studio and firmware?

Daniel, thank you for the update! If you think the final version should be ready this week wait for the final, beta is not necessary, thank you!

Got it, the V2.3.0 should be released tomorrow, I will share the installation package with Google driver link.

1 Like

Hi, please download the installation package here:

Please use Studio, go to Settings-My device-Check update, click ‘Install’ to install this package.

I just installed it, I did some simple initial testing and it looks like it is working great! Awesome job! thank you for your attention to this matter and the quick turnaround time, I’m sure this will help lots of XARM users out there. side note: looks like you did a nice facelift on the UI for the software as well in this update, it looks great! thanks again :slight_smile:

We are very glad to hear that. Thanks very much for your feedback.